aboutsummaryrefslogtreecommitdiffstats
path: root/app-misc/animdl/animdl-1.17.22-r1.ebuild
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-08-30 17:34:16 -0500
committerturret <turret@duck.com>2023-08-30 17:34:16 -0500
commit5cb6312a6d8e1cb790d4b08bca18fa46b4947d79 (patch)
tree30bc38ab64604e37c6b7b7c4c49a5a91fc689e2d /app-misc/animdl/animdl-1.17.22-r1.ebuild
parent8a4685ab41373fe48a9fd4373fa3a937adc1a888 (diff)
downloadportage-overlay-5cb6312a6d8e1cb790d4b08bca18fa46b4947d79.tar.gz
portage-overlay-5cb6312a6d8e1cb790d4b08bca18fa46b4947d79.tar.bz2
portage-overlay-5cb6312a6d8e1cb790d4b08bca18fa46b4947d79.zip
dev-python/animdl: rev bump, python3_12
Signed-off-by: turret <turret@duck.com>
Diffstat (limited to 'app-misc/animdl/animdl-1.17.22-r1.ebuild')
-rw-r--r--app-misc/animdl/animdl-1.17.22-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/animdl/animdl-1.17.22-r1.ebuild b/app-misc/animdl/animdl-1.17.22-r1.ebuild
new file mode 100644
index 0000000..23af879
--- /dev/null
+++ b/app-misc/animdl/animdl-1.17.22-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_11 python3_12 )
+inherit distutils-r1
+
+DESCRIPTION="A highly efficient, powerful and fast anime scraper."
+HOMEPAGE="https://github.com/justfoolingaround/animdl"
+
+if [[ "${PV}" == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/justfoolingaround/animdl.git"
+ inherit git-r3
+else
+ SRC_URI="https://cdn.turret.cyou/2f1ddc4a5434af402ffb1de1acf4b9d38499d93a/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pip
+ dev-python/poetry-core
+ dev-python/anchor-kr
+ dev-python/anitopy
+ dev-python/click
+ dev-python/cssselect
+ dev-python/httpx
+ dev-python/tqdm
+ dev-python/pycryptodomex
+ dev-python/regex
+ dev-python/yarl
+ dev-python/pyyaml
+ dev-python/packaging
+ dev-python/pkginfo
+ dev-python/rich"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv "${PN}" "${P}" || die
+}