From 7efbb2b8ea9b9942e16dbaa8ea9eca60fd938a67 Mon Sep 17 00:00:00 2001
From: turret <turret@duck.com>
Date: Tue, 5 Sep 2023 19:30:18 -0500
Subject: games-util/grapejuice: version bump 7.20.11

Signed-off-by: turret <turret@duck.com>
---
 games-util/grapejuice/Manifest                  |  2 +-
 games-util/grapejuice/grapejuice-7.19.8.ebuild  | 83 -------------------------
 games-util/grapejuice/grapejuice-7.20.11.ebuild | 83 +++++++++++++++++++++++++
 3 files changed, 84 insertions(+), 84 deletions(-)
 delete mode 100644 games-util/grapejuice/grapejuice-7.19.8.ebuild
 create mode 100644 games-util/grapejuice/grapejuice-7.20.11.ebuild

diff --git a/games-util/grapejuice/Manifest b/games-util/grapejuice/Manifest
index c9cbe52..ff95a76 100644
--- a/games-util/grapejuice/Manifest
+++ b/games-util/grapejuice/Manifest
@@ -1 +1 @@
-DIST grapejuice-v7.19.8.tar.bz2 956844 BLAKE2B 7bfbecf1f5d58b24b5f44f0a2adfcbc6c2d76380ab140f4c08b513004cc71603ae62c7a50237a9bcba551c2ada534bcd8a107b9cf6ed19b5ceb331fd2613b7ac SHA512 6ff6e7ce2a190ce6442ebbf02f2293b9c6c7218d766e46ab7ca6d7a3d2479143aa252042d09b4c8f376cea719f292a8543f3f7ff1c7ef83c9649ca0d7bb3857c
+DIST grapejuice-v7.20.11.tar.bz2 957454 BLAKE2B 1553082da9d17f1c22b39ec9d8a1a1f034c1ea64362295edc5a4e0131b0063e2b01aafbe5b1959703c293baabdbdd5c8a385368ef4917cd1b5c25d87b50b6a53 SHA512 f708898961202a7926353cc2163f0c74da0cd32a25f60285e31508aa9087be79c03b88c727e4bca02a6befac4d6875c04269c520719bc026f05045b0c2474897
diff --git a/games-util/grapejuice/grapejuice-7.19.8.ebuild b/games-util/grapejuice/grapejuice-7.19.8.ebuild
deleted file mode 100644
index d0253bb..0000000
--- a/games-util/grapejuice/grapejuice-7.19.8.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit xdg optfeature
-
-DESCRIPTION="A Wine+Roblox management application"
-HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
-
-if [[ ${PV} == *9999* ]]; then
-	inherit git-r3
-	EGIT_REPO_URI="https://gitlab.com/brinkervii/grapejuice.git"
-	EGIT_BRANCH="staging"
-else
-	SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.tar.bz2"
-	KEYWORDS="-* ~amd64"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-RESTRICT="mirror"
-
-DEPEND="dev-libs/gobject-introspection
-		dev-python/pip
-		dev-util/desktop-file-utils
-		dev-util/gtk-update-icon-cache
-		dev-vcs/git
-		sys-devel/gettext
-		x11-apps/mesa-progs
-		x11-libs/cairo
-		x11-libs/gtk+
-		x11-misc/shared-mime-info
-		x11-misc/xdg-user-dirs
-		x11-misc/xdg-utils
-
-		dev-python/click
-		dev-python/packaging
-		dev-python/psutil
-		dev-python/pydantic
-		dev-python/pygobject
-		dev-python/requests
-		dev-python/setuptools
-		dev-python/unidecode
-		dev-python/wheel"
-
-RDEPEND="
-		${DEPEND}
-		virtual/wine"
-
-src_unpack() {
-	default
-	if [[ ${PV} == *9999* ]]; then
-		git-r3_src_unpack
-	else
-		mv "${WORKDIR}/grapejuice-v${PV}" "${S}" || die
-	fi
-}
-
-src_prepare() {
-	default
-	sed -i \
-		-e 's/"--target"/"--no-build-isolation",\n\t\t"--target"/' \
-		src/grapejuice_packaging/builders/linux_package_builder.py || die
-}
-
-src_compile() {
-	cd "${S}"
-	export PYTHONPATH="${S}/src"
-	python3 -m grapejuice_packaging linux_package || die
-}
-
-src_install() {
-	export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
-	tar -xf "${S}/dist/linux_package"/*.tar.gz -C "${D}" || die
-	mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}" || die
-	rm -r "${D}/usr/lib/python3" || die
-	default
-}
-
-pkg_postinst() {
-	optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
-}
diff --git a/games-util/grapejuice/grapejuice-7.20.11.ebuild b/games-util/grapejuice/grapejuice-7.20.11.ebuild
new file mode 100644
index 0000000..d0253bb
--- /dev/null
+++ b/games-util/grapejuice/grapejuice-7.20.11.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg optfeature
+
+DESCRIPTION="A Wine+Roblox management application"
+HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
+
+if [[ ${PV} == *9999* ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://gitlab.com/brinkervii/grapejuice.git"
+	EGIT_BRANCH="staging"
+else
+	SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.tar.bz2"
+	KEYWORDS="-* ~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+DEPEND="dev-libs/gobject-introspection
+		dev-python/pip
+		dev-util/desktop-file-utils
+		dev-util/gtk-update-icon-cache
+		dev-vcs/git
+		sys-devel/gettext
+		x11-apps/mesa-progs
+		x11-libs/cairo
+		x11-libs/gtk+
+		x11-misc/shared-mime-info
+		x11-misc/xdg-user-dirs
+		x11-misc/xdg-utils
+
+		dev-python/click
+		dev-python/packaging
+		dev-python/psutil
+		dev-python/pydantic
+		dev-python/pygobject
+		dev-python/requests
+		dev-python/setuptools
+		dev-python/unidecode
+		dev-python/wheel"
+
+RDEPEND="
+		${DEPEND}
+		virtual/wine"
+
+src_unpack() {
+	default
+	if [[ ${PV} == *9999* ]]; then
+		git-r3_src_unpack
+	else
+		mv "${WORKDIR}/grapejuice-v${PV}" "${S}" || die
+	fi
+}
+
+src_prepare() {
+	default
+	sed -i \
+		-e 's/"--target"/"--no-build-isolation",\n\t\t"--target"/' \
+		src/grapejuice_packaging/builders/linux_package_builder.py || die
+}
+
+src_compile() {
+	cd "${S}"
+	export PYTHONPATH="${S}/src"
+	python3 -m grapejuice_packaging linux_package || die
+}
+
+src_install() {
+	export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
+	tar -xf "${S}/dist/linux_package"/*.tar.gz -C "${D}" || die
+	mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}" || die
+	rm -r "${D}/usr/lib/python3" || die
+	default
+}
+
+pkg_postinst() {
+	optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
+}
-- 
cgit v1.2.3