From 5d237600a82037567b8e3a06c35fb7aace45f2f6 Mon Sep 17 00:00:00 2001
From: turret <turret@duck.com>
Date: Wed, 30 Aug 2023 17:34:32 -0500
Subject: games-action/portablemc: rev bump, python3_12

Signed-off-by: turret <turret@duck.com>
---
 games-action/portablemc/Manifest                   |  2 +-
 games-action/portablemc/portablemc-4.0.2-r1.ebuild | 28 ++++++++++++++++++++++
 games-action/portablemc/portablemc-4.0.2.ebuild    | 28 ----------------------
 3 files changed, 29 insertions(+), 29 deletions(-)
 create mode 100644 games-action/portablemc/portablemc-4.0.2-r1.ebuild
 delete mode 100644 games-action/portablemc/portablemc-4.0.2.ebuild

(limited to 'games-action/portablemc')

diff --git a/games-action/portablemc/Manifest b/games-action/portablemc/Manifest
index 75ca02c..239f389 100644
--- a/games-action/portablemc/Manifest
+++ b/games-action/portablemc/Manifest
@@ -1,3 +1,3 @@
 DIST portablemc-4.0.2.tar.gz 1091835 BLAKE2B a12bda770e1989a8cfcec83f6abae0a743870b30eb8b3424d725886dc243c76646c3b9cba4c56ba673aff3d84f06210493b6c07ab3a70bfbc36ae16905a093ef SHA512 7a11045d9f3c20da52020ec2559ea62375cc22a8f9c2089bfc682724b5b24cde82751e2420fcf687bdbe59efab9968a9d5793f8864901ec7279f69ebe6f1a9dc
-EBUILD portablemc-4.0.2.ebuild 721 BLAKE2B 17a0a0dac5ef9d259b8da9f3b54930279eef8c8f25ac3665fd4302110d6292cffc5f6ab528a62848e3b59439db5c46078d38fda0ad5a7fc4f8d908cbd95e8f77 SHA512 1da4e97cd85211281626cc57cf35754b83ef66de6584e6e730dd20862d76bee1335500bc0ebeb6ed17ee60b878fa5f674a76185a4942e5c8ee1125bc0f19d9c3
+EBUILD portablemc-4.0.2-r1.ebuild 721 BLAKE2B 17a0a0dac5ef9d259b8da9f3b54930279eef8c8f25ac3665fd4302110d6292cffc5f6ab528a62848e3b59439db5c46078d38fda0ad5a7fc4f8d908cbd95e8f77 SHA512 1da4e97cd85211281626cc57cf35754b83ef66de6584e6e730dd20862d76bee1335500bc0ebeb6ed17ee60b878fa5f674a76185a4942e5c8ee1125bc0f19d9c3
 MISC metadata.xml 358 BLAKE2B 5e594853aed3c5658a530f880214253a17ed1f2a7f90024da06fca3c956aeb4ba8482586079b8fdaec2600303a11f4e9410f02d363008c9b9cce91242c1769af SHA512 3b10c2701398ef84d1b70ab56762c31905893ec5f22f519b6e3f0a64090840678d97fedd1846551838bf4e481e254963419d74f0be89d1d4104497d4d7f01339
diff --git a/games-action/portablemc/portablemc-4.0.2-r1.ebuild b/games-action/portablemc/portablemc-4.0.2-r1.ebuild
new file mode 100644
index 0000000..375792b
--- /dev/null
+++ b/games-action/portablemc/portablemc-4.0.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_11 python3_12 )
+inherit distutils-r1
+
+DESCRIPTION="An easy-to-use and extensible Python CLI Minecraft launcher with compatability!"
+HOMEPAGE="https://github.com/mindstorm38/portablemc"
+if [[ ${PV} == 9999 ]] ; then
+	EGIT_REPO_URI="https://github.com/mindstorm38/portablemc.git"
+	inherit git-r3
+else
+	SRC_URI="https://github.com/mindstorm38/portablemc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+DEPEND="${PYTHON_DEPS}
+		dev-python/pip
+		dev-python/poetry-core"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
diff --git a/games-action/portablemc/portablemc-4.0.2.ebuild b/games-action/portablemc/portablemc-4.0.2.ebuild
deleted file mode 100644
index 2b3d8eb..0000000
--- a/games-action/portablemc/portablemc-4.0.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_11 )
-inherit distutils-r1
-
-DESCRIPTION="An easy-to-use and extensible Python CLI Minecraft launcher with compatability!"
-HOMEPAGE="https://github.com/mindstorm38/portablemc"
-if [[ ${PV} == 9999 ]] ; then
-	EGIT_REPO_URI="https://github.com/mindstorm38/portablemc.git"
-	inherit git-r3
-else
-	SRC_URI="https://github.com/mindstorm38/portablemc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-	KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-RESTRICT="mirror"
-
-DEPEND="${PYTHON_DEPS}
-		dev-python/pip
-		dev-python/poetry-core"
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-- 
cgit v1.2.3