aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-12-08 21:51:18 -0600
committerturret <turret@duck.com>2023-12-08 21:51:18 -0600
commit4bc9d1a35047c8c596e8e893f5a1de7a80699e10 (patch)
tree38662fe3ee3f9a7bbe5a6f7fa2b6c560240f55f4
parenta780240bdac5db4df0310f0765b756cc6fb7d93e (diff)
downloadportage-overlay-4bc9d1a35047c8c596e8e893f5a1de7a80699e10.tar.gz
portage-overlay-4bc9d1a35047c8c596e8e893f5a1de7a80699e10.tar.bz2
portage-overlay-4bc9d1a35047c8c596e8e893f5a1de7a80699e10.zip
app-text/zathura: add 0.5.3
just do i don't forget to merge it to gentoo.git later
-rw-r--r--app-text/zathura/Manifest2
-rw-r--r--app-text/zathura/files/zathura-0.5.3-disable-seccomp-tests.patch24
-rw-r--r--app-text/zathura/zathura-0.5.3.ebuild73
3 files changed, 99 insertions, 0 deletions
diff --git a/app-text/zathura/Manifest b/app-text/zathura/Manifest
new file mode 100644
index 0000000..e4e49ac
--- /dev/null
+++ b/app-text/zathura/Manifest
@@ -0,0 +1,2 @@
+DIST zathura-0.5.3-manpages.tar.xz 10064 BLAKE2B f2d9988bfa1edf79b64be460c242ddf6fae15d84a6e0f8e25011962f24a3aca77a15ce285dc7e742693e28aff70da9f6f311f56ceafbda1439f2a6e347a973f8 SHA512 49269eca809a5c468f759991114a8beeeadb2e82b38c9126c89c63c2b90aa6a02624e5971c9d175c52abd724d23f48b05d03ba469397da5d12925ed8cdf11668
+DIST zathura-0.5.3.tar.gz 216701 BLAKE2B 0a39dc4d7f0d2ec36a9e52a8b9c606c56ed48cb9d37eb232303a596f386a9d980cef96e549efc461f577f286793861ee6654a72ebdfe8fbda25022e4ce38f657 SHA512 236dc981978d3fc7999be47d87d4ca9aaca03bfa1e069cd22c41bd93231248061faf7df62b2371dd28b17ec3f381ce2fff908f6b26ad211b529f51b9b1dabb53
diff --git a/app-text/zathura/files/zathura-0.5.3-disable-seccomp-tests.patch b/app-text/zathura/files/zathura-0.5.3-disable-seccomp-tests.patch
new file mode 100644
index 0000000..1d9d0a5
--- /dev/null
+++ b/app-text/zathura/files/zathura-0.5.3-disable-seccomp-tests.patch
@@ -0,0 +1,24 @@
+diff --git a/tests/meson.build b/tests/meson.build
+index d2bed1d..9dbb6df 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -44,18 +44,7 @@ if check.found()
+ test('session', xvfb,
+ args: ['-a', '-s', '-screen 0 1400x900x24 -ac +extension GLX +render -noreset', session],
+ timeout: 60*60
+- )
+-
+- if seccomp.found()
+- sandbox = executable('test_sandbox', ['test_sandbox.c', 'tests.c'],
+- dependencies: build_dependencies + test_dependencies,
+- include_directories: include_directories,
+- c_args: defines + flags
+ )
+- test('sandbox', xvfb,
+- args: ['-a', '-s', '-screen 0 1400x900x24 -ac +extension GLX +render -noreset', sandbox],
+- timeout: 60*60
+- )
+- endif
++
+ endif
+ endif
diff --git a/app-text/zathura/zathura-0.5.3.ebuild b/app-text/zathura/zathura-0.5.3.ebuild
new file mode 100644
index 0000000..7e82398
--- /dev/null
+++ b/app-text/zathura/zathura-0.5.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson virtualx xdg
+
+DESCRIPTION="A highly customizable and functional document viewer"
+HOMEPAGE="https://pwmt.org/projects/zathura/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="
+ https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://cdn.turret.cyou/e28b2f940d1a19a74ecbfd80ea4477c5ea9ac627/${P}-manpages.tar.xz
+ "
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="ZLIB"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="seccomp sqlite synctex test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/girara-0.4.1
+ >=dev-libs/glib-2.50:2
+ dev-libs/json-glib
+ sys-apps/file
+ >=sys-devel/gettext-0.19.8
+ x11-libs/cairo
+ >=x11-libs/gtk+-3.22:3
+ seccomp? ( sys-libs/libseccomp )
+ sqlite? ( >=dev-db/sqlite-3.6.23:3 )
+ synctex? ( app-text/texlive-core )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ test? (
+ dev-libs/appstream-glib
+ dev-libs/check
+ x11-base/xorg-server[xvfb]
+ )
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-disable-seccomp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dconvert-icon=disabled
+ -Dmanpages=disabled
+ -Dseccomp=$(usex seccomp enabled disabled)
+ -Dsqlite=$(usex sqlite enabled disabled)
+ -Dsynctex=$(usex synctex enabled disabled)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+ [[ ${PV} != *9999 ]] && doman "${WORKDIR}"/man/zathura*
+}