aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-06-27 10:16:14 -0500
committerturret <turret@duck.com>2023-06-27 10:16:14 -0500
commit0907a97b8e17a95ba1521e94bc7fcf17e9ff64c9 (patch)
treeb11ec55d4c8e7854dfdf8c2416dd07d4b2ed7f99
parent0c90ec29a55ed5babc9ebbe485ef113c4bbddddc (diff)
downloadportage-overlay-0907a97b8e17a95ba1521e94bc7fcf17e9ff64c9.tar.gz
portage-overlay-0907a97b8e17a95ba1521e94bc7fcf17e9ff64c9.tar.bz2
portage-overlay-0907a97b8e17a95ba1521e94bc7fcf17e9ff64c9.zip
games-action/portablemc-3.3.1: new package
-rw-r--r--games-action/portablemc/Manifest3
-rw-r--r--games-action/portablemc/metadata.xml11
-rw-r--r--games-action/portablemc/portablemc-3.3.1.ebuild33
-rw-r--r--metadata/md5-cache/games-action/portablemc-3.3.117
4 files changed, 64 insertions, 0 deletions
diff --git a/games-action/portablemc/Manifest b/games-action/portablemc/Manifest
new file mode 100644
index 0000000..e338ea9
--- /dev/null
+++ b/games-action/portablemc/Manifest
@@ -0,0 +1,3 @@
+DIST portablemc-3.3.1.tar.gz 3127408 BLAKE2B 25f4898d23ae3122d135be65065d358fa4554cb62daca56c999d1ce2d2e2ad47710c3f6546301730d38e6b646e818a72e351aa8d7de29962c9af97d3a0fa7327 SHA512 6ddc1e9a94af829e7c9e039d1fcbbf24887f3861ba199ca71d18808426c56919dcf986c35956d7d2e4fbd1f6ba7448ed255eb91201ba2b0e28a9c085b0ba93cd
+EBUILD portablemc-3.3.1.ebuild 795 BLAKE2B 2aa2fce8b545c0f887871faf44a4fdd7ccb193db5df58b56782b0944c5fd40f85168ca7d556f8677d7bc062542f7bb7cfff67e8033b64a8e749fd8e8a8b9595b SHA512 bebcf140abc91bb72d03edf6f199e18106fe01ef22acbbcd96eb631c25c1978122e33f73ceff9b6dcaf493844e25cfabdf75ae8918cf3ad62dd90c529b18590c
+MISC metadata.xml 358 BLAKE2B 5e594853aed3c5658a530f880214253a17ed1f2a7f90024da06fca3c956aeb4ba8482586079b8fdaec2600303a11f4e9410f02d363008c9b9cce91242c1769af SHA512 3b10c2701398ef84d1b70ab56762c31905893ec5f22f519b6e3f0a64090840678d97fedd1846551838bf4e481e254963419d74f0be89d1d4104497d4d7f01339
diff --git a/games-action/portablemc/metadata.xml b/games-action/portablemc/metadata.xml
new file mode 100644
index 0000000..a8dd215
--- /dev/null
+++ b/games-action/portablemc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>turret@turret.cyou</email>
+ <name>turret</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mindstorm38/portablemc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/portablemc/portablemc-3.3.1.ebuild b/games-action/portablemc/portablemc-3.3.1.ebuild
new file mode 100644
index 0000000..1f9b3c2
--- /dev/null
+++ b/games-action/portablemc/portablemc-3.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_11 )
+inherit distutils-r1
+
+DESCRIPTION="An easy-to-use and extensible Python CLI Minecraft launcher with compatability!"
+HOMEPAGE="https://github.com/mindstorm38/portablemc"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/mindstorm38/portablemc.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/mindstorm38/portablemc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pip
+ dev-python/poetry-core"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv "${WORKDIR}/${P}/src/core/"* "${S}" || die
+}
diff --git a/metadata/md5-cache/games-action/portablemc-3.3.1 b/metadata/md5-cache/games-action/portablemc-3.3.1
new file mode 100644
index 0000000..a41e867
--- /dev/null
+++ b/metadata/md5-cache/games-action/portablemc-3.3.1
@@ -0,0 +1,17 @@
+BDEPEND=python_targets_python3_11? ( >=dev-lang/python-3.11.3:3.11 ) dev-python/pip dev-python/poetry-core python_targets_python3_11? ( >=dev-lang/python-3.11.3:3.11 ) >=dev-python/gpep517-13[python_targets_python3_11(-)?] >=dev-python/poetry-core-1.5.2[python_targets_python3_11(-)?]
+DEFINED_PHASES=compile configure install prepare test unpack
+DEPEND=python_targets_python3_11? ( >=dev-lang/python-3.11.3:3.11 ) dev-python/pip dev-python/poetry-core
+DESCRIPTION=An easy-to-use and extensible Python CLI Minecraft launcher with compatability!
+EAPI=8
+HOMEPAGE=https://github.com/mindstorm38/portablemc
+INHERIT=distutils-r1
+IUSE=python_targets_python3_11
+KEYWORDS=~amd64
+LICENSE=GPL-3
+RDEPEND=python_targets_python3_11? ( >=dev-lang/python-3.11.3:3.11 ) dev-python/pip dev-python/poetry-core python_targets_python3_11? ( >=dev-lang/python-3.11.3:3.11 )
+REQUIRED_USE=|| ( python_targets_python3_11 )
+RESTRICT=mirror
+SLOT=0
+SRC_URI=https://github.com/mindstorm38/portablemc/archive/refs/tags/v3.3.1.tar.gz -> portablemc-3.3.1.tar.gz
+_eclasses_=out-of-source-utils 1a9007554652a6e627edbccb3c25a439 multibuild bddcb51b74f4a76724ff7cf8e7388869 multilib c19072c3cd7ac5cb21de013f7e9832e0 toolchain-funcs 513c31b3346458ed1f3878b57da6d61c multiprocessing b4e253ab22cef7b1085e9b67c7a3b730 ninja-utils 76050953ad5b70d7e09a6ca55558db92 python-utils-r1 a34d5f83235297b76d71eaf8deb53768 python-r1 3c6cd0f418ba702c186a9865b85e704d distutils-r1 2d32e797ee29a8ffdd452f4a85860666
+_md5_=93efa5203ab39491e1be64cb67986d57