aboutsummaryrefslogtreecommitdiffstats
path: root/app-misc/animdl/animdl-1.17.22.ebuild
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-08-14 17:55:01 -0500
committerturret <turret@duck.com>2023-08-14 17:55:01 -0500
commit8ef2464af8607c9a107da4bed911d27f28fb5ff8 (patch)
treeb86ec87cefcb6a7e5a12a27bc43d8f58a6304387 /app-misc/animdl/animdl-1.17.22.ebuild
parent08d1ff4e02333ea98e9a6bf67b5ec64a9c148618 (diff)
downloadportage-overlay-8ef2464af8607c9a107da4bed911d27f28fb5ff8.tar.gz
portage-overlay-8ef2464af8607c9a107da4bed911d27f28fb5ff8.tar.bz2
portage-overlay-8ef2464af8607c9a107da4bed911d27f28fb5ff8.zip
app-misc/animdl-1.17.22: version bump
Diffstat (limited to 'app-misc/animdl/animdl-1.17.22.ebuild')
-rw-r--r--app-misc/animdl/animdl-1.17.22.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/animdl/animdl-1.17.22.ebuild b/app-misc/animdl/animdl-1.17.22.ebuild
new file mode 100644
index 0000000..815041c
--- /dev/null
+++ b/app-misc/animdl/animdl-1.17.22.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_11 )
+inherit distutils-r1
+
+DESCRIPTION="A highly efficient, powerful and fast anime scraper."
+HOMEPAGE="https://github.com/justfoolingaround/animdl"
+
+if [[ "${PV}" == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/justfoolingaround/animdl.git"
+ inherit git-r3
+else
+ SRC_URI="https://cdn.turret.cyou/2f1ddc4a5434af402ffb1de1acf4b9d38499d93a/animdl-1.17.22.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pip
+ dev-python/poetry-core
+ dev-python/anchor-kr
+ dev-python/anitopy
+ dev-python/click
+ dev-python/cssselect
+ dev-python/httpx
+ dev-python/tqdm
+ dev-python/pycryptodomex
+ dev-python/regex
+ dev-python/yarl
+ dev-python/pyyaml
+ dev-python/packaging
+ dev-python/pkginfo
+ dev-python/rich"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv "${PN}" "${P}" || die
+}