aboutsummaryrefslogtreecommitdiffstats
path: root/app-misc/animdl/animdl-1.7.24.ebuild
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-09-14 17:18:27 -0500
committerturret <turret@duck.com>2023-09-14 17:18:27 -0500
commitacaacde6c66de75080a92a0fcef01342702b6cb1 (patch)
treec8e0b0b007e954c30d123447b93d654ab5269be0 /app-misc/animdl/animdl-1.7.24.ebuild
parent7efbb2b8ea9b9942e16dbaa8ea9eca60fd938a67 (diff)
downloadportage-overlay-acaacde6c66de75080a92a0fcef01342702b6cb1.tar.gz
portage-overlay-acaacde6c66de75080a92a0fcef01342702b6cb1.tar.bz2
portage-overlay-acaacde6c66de75080a92a0fcef01342702b6cb1.zip
app-misc/animdl: version bump 1.7.24
Diffstat (limited to 'app-misc/animdl/animdl-1.7.24.ebuild')
-rw-r--r--app-misc/animdl/animdl-1.7.24.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/animdl/animdl-1.7.24.ebuild b/app-misc/animdl/animdl-1.7.24.ebuild
new file mode 100644
index 0000000..9ecceba
--- /dev/null
+++ b/app-misc/animdl/animdl-1.7.24.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_11 python3_12 )
+inherit distutils-r1
+
+DESCRIPTION="A highly efficient, powerful and fast anime scraper."
+HOMEPAGE="https://github.com/justfoolingaround/animdl"
+
+if [[ "${PV}" == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/justfoolingaround/animdl.git"
+ inherit git-r3
+else
+ SRC_URI="https://cdn.turret.cyou/6b4a2a75bc566e72187d49b166cd1e9c1d93cf17/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pip
+ dev-python/poetry-core
+ dev-python/anchor-kr
+ dev-python/anitopy
+ dev-python/click
+ dev-python/cssselect
+ dev-python/httpx
+ dev-python/tqdm
+ dev-python/pycryptodomex
+ dev-python/regex
+ dev-python/yarl
+ dev-python/pyyaml
+ dev-python/packaging
+ dev-python/pkginfo
+ dev-python/rich"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv "${PN}" "${P}" || die
+}