aboutsummaryrefslogtreecommitdiffstats
path: root/app-vim/vim-ledger/vim-ledger-1.2.0.ebuild
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-03-04 18:40:48 -0600
committerturret <turret@duck.com>2023-03-04 18:40:48 -0600
commitb81c44d17494c39df2b47e1ea35c750711828fd0 (patch)
treefb3a7ae63112a3b54e37545e8a107ab38e577744 /app-vim/vim-ledger/vim-ledger-1.2.0.ebuild
parent9559211f759f89be2adda05cf1ace3561a8d158c (diff)
downloadportage-overlay-b81c44d17494c39df2b47e1ea35c750711828fd0.tar.gz
portage-overlay-b81c44d17494c39df2b47e1ea35c750711828fd0.tar.bz2
portage-overlay-b81c44d17494c39df2b47e1ea35c750711828fd0.zip
add vim ledger
Diffstat (limited to 'app-vim/vim-ledger/vim-ledger-1.2.0.ebuild')
-rw-r--r--app-vim/vim-ledger/vim-ledger-1.2.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/vim-ledger/vim-ledger-1.2.0.ebuild b/app-vim/vim-ledger/vim-ledger-1.2.0.ebuild
new file mode 100644
index 0000000..76bbfbc
--- /dev/null
+++ b/app-vim/vim-ledger/vim-ledger-1.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild,v 1.6 2013/06/01 09:32:03 radhermit Exp $
+
+EAPI=7
+
+inherit vim-plugin
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ledger/vim-ledger"
+else
+ SRC_URI="https://github.com/ledger/vim-ledger/archive/refs/tags/v$PV.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RESTRICT=primaryuri
+DESCRIPTION="vim plugin: app-office/ledger file format syntax"
+HOMEPAGE="https://github.com/ledger/vim-ledger"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="ledger-syntax"
+VIM_PLUGIN_MESSAGES="filetype"