aboutsummaryrefslogtreecommitdiffstats
path: root/dev-python
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-06-30 23:07:08 -0500
committerturret <turret@duck.com>2023-06-30 23:07:08 -0500
commit36cdca2ab7c038bba12a9cb5140c0d0276b63972 (patch)
tree5536fbc147193849039c6e9916c670341866b2b8 /dev-python
parent9926cdc47b2177dad000ea5bae4b7ef85ef6f880 (diff)
downloadportage-overlay-36cdca2ab7c038bba12a9cb5140c0d0276b63972.tar.gz
portage-overlay-36cdca2ab7c038bba12a9cb5140c0d0276b63972.tar.bz2
portage-overlay-36cdca2ab7c038bba12a9cb5140c0d0276b63972.zip
app-misc/animdl: reference correct package, new pkg cryptodomex
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycryptodomex/Manifest2
-rw-r--r--dev-python/pycryptodomex/metadata.xml11
-rw-r--r--dev-python/pycryptodomex/pycryptodomex-3.18.0x.ebuild36
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pycryptodomex/Manifest b/dev-python/pycryptodomex/Manifest
new file mode 100644
index 0000000..296da55
--- /dev/null
+++ b/dev-python/pycryptodomex/Manifest
@@ -0,0 +1,2 @@
+DIST pycryptodomex-3.18.0x.tar.gz 16720774 BLAKE2B 76d0e43b3443b1bd0d2fc29bf5f90d2946a0deac18ed84b8b39a531fe9d7a3e3f3b1854acb1834502697327f5a982865b77feda5a3c513329e79429434d7f39f SHA512 233506bfbc173f531da750844be578819d51bb273e0a8cd02ec9356ee3ac96fb87b9481227fe2fa4c85fcdb883eb8a142cb9bb638089fc57481d8ecca2476baf
+EBUILD pycryptodomex-3.18.0x.ebuild 823 BLAKE2B 75f51cb4abfa26ae0b3ee7fea81f6613125b1302fb56792b5542db3f5930e0d8396c0f6356c28238f6b7f8d18b81fc795836971396361ecee016280c420b5ad7 SHA512 26145eee95dc8235a5be853f34a8f9663b414df218af43d86a928bdf9de673e7f2d1959482397bf08c11a832d09fac3c363b4a55b0d6ddcc67ce8532533f7868
diff --git a/dev-python/pycryptodomex/metadata.xml b/dev-python/pycryptodomex/metadata.xml
new file mode 100644
index 0000000..eef02a5
--- /dev/null
+++ b/dev-python/pycryptodomex/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>turret@turret.cyou</email>
+ <name>turret</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Legrandin/pycryptodome</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pycryptodomex/pycryptodomex-3.18.0x.ebuild b/dev-python/pycryptodomex/pycryptodomex-3.18.0x.ebuild
new file mode 100644
index 0000000..1f4862c
--- /dev/null
+++ b/dev-python/pycryptodomex/pycryptodomex-3.18.0x.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_11 )
+inherit distutils-r1
+
+DESCRIPTION="Python package of low-level cryptographic primitives"
+HOMEPAGE="https://github.com/Legrandin/pycryptodome"
+
+if [[ "${PV}" == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Legrandin/pycryptodome.git"
+ EGIT_BRANCH="pycryptodomex"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Legrandin/pycryptodome/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pip"
+
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv "pycryptodome-${PV}" "${P}" || die
+}