aboutsummaryrefslogtreecommitdiffstats
path: root/games-util/grapejuice/grapejuice-9999.ebuild
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-11-11 17:15:54 -0600
committerturret <turret@duck.com>2023-11-11 17:16:03 -0600
commit5cccf54d0b288a79785f8142954f37d4fc34ab54 (patch)
treed381152825cb7d5092535535003c1c05c034454a /games-util/grapejuice/grapejuice-9999.ebuild
parentee42e4b0c453a10925a5d9e6aa87fc8dfea4c798 (diff)
downloadportage-overlay-5cccf54d0b288a79785f8142954f37d4fc34ab54.tar.gz
portage-overlay-5cccf54d0b288a79785f8142954f37d4fc34ab54.tar.bz2
portage-overlay-5cccf54d0b288a79785f8142954f37d4fc34ab54.zip
games-util/grapejuice: sync with guru
Diffstat (limited to 'games-util/grapejuice/grapejuice-9999.ebuild')
-rw-r--r--games-util/grapejuice/grapejuice-9999.ebuild30
1 files changed, 12 insertions, 18 deletions
diff --git a/games-util/grapejuice/grapejuice-9999.ebuild b/games-util/grapejuice/grapejuice-9999.ebuild
index d0253bb..147b21f 100644
--- a/games-util/grapejuice/grapejuice-9999.ebuild
+++ b/games-util/grapejuice/grapejuice-9999.ebuild
@@ -3,10 +3,10 @@
EAPI=8
-inherit xdg optfeature
+inherit xdg
DESCRIPTION="A Wine+Roblox management application"
-HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
+HOMEPAGE="https://gitlab.com/brinkervii/grapejuice"
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -19,10 +19,18 @@ fi
LICENSE="GPL-3"
SLOT="0"
-RESTRICT="mirror"
DEPEND="dev-libs/gobject-introspection
+ dev-python/click
+ dev-python/packaging
dev-python/pip
+ dev-python/psutil
+ dev-python/pydantic
+ dev-python/pygobject
+ dev-python/requests
+ dev-python/setuptools
+ dev-python/unidecode
+ dev-python/wheel
dev-util/desktop-file-utils
dev-util/gtk-update-icon-cache
dev-vcs/git
@@ -32,17 +40,7 @@ DEPEND="dev-libs/gobject-introspection
x11-libs/gtk+
x11-misc/shared-mime-info
x11-misc/xdg-user-dirs
- x11-misc/xdg-utils
-
- dev-python/click
- dev-python/packaging
- dev-python/psutil
- dev-python/pydantic
- dev-python/pygobject
- dev-python/requests
- dev-python/setuptools
- dev-python/unidecode
- dev-python/wheel"
+ x11-misc/xdg-utils"
RDEPEND="
${DEPEND}
@@ -77,7 +75,3 @@ src_install() {
rm -r "${D}/usr/lib/python3" || die
default
}
-
-pkg_postinst() {
- optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
-}