aboutsummaryrefslogtreecommitdiffstats
path: root/gui-wm/cage/cage-9999.ebuild
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-05-21 17:47:44 -0500
committerturret <turret@duck.com>2023-05-21 17:47:44 -0500
commit47949a98e88419536175e2eca88b2b72ef06c181 (patch)
tree8012bc1563c4430966525889cf7d951b73d4d476 /gui-wm/cage/cage-9999.ebuild
parent8f8d6a00599012882349ae6eb7f9cc86fcc6ab71 (diff)
downloadportage-overlay-47949a98e88419536175e2eca88b2b72ef06c181.tar.gz
portage-overlay-47949a98e88419536175e2eca88b2b72ef06c181.tar.bz2
portage-overlay-47949a98e88419536175e2eca88b2b72ef06c181.zip
add cage, dwl, and gentoo-sources, grapejuice symlinks
Diffstat (limited to 'gui-wm/cage/cage-9999.ebuild')
-rw-r--r--gui-wm/cage/cage-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/gui-wm/cage/cage-9999.ebuild b/gui-wm/cage/cage-9999.ebuild
new file mode 100644
index 0000000..b463a12
--- /dev/null
+++ b/gui-wm/cage/cage-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ "${PV}" == 9999 ]]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Hjdskes/cage"
+else
+ SRC_URI="https://github.com/Hjdskes/cage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A Wayland kiosk"
+HOMEPAGE="https://www.hjdskes.nl/projects/cage/ https://github.com/Hjdskes/cage"
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="X"
+
+RDEPEND="
+ >=gui-libs/wlroots-0.14[X?]
+ x11-libs/libxkbcommon[X?]
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ meson_src_configure $(meson_use X xwayland)
+}