aboutsummaryrefslogtreecommitdiffstats
path: root/gui-wm/dwl/dwl-0.3.1.ebuild
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-05-21 17:47:44 -0500
committerturret <turret@duck.com>2023-05-21 17:47:44 -0500
commit47949a98e88419536175e2eca88b2b72ef06c181 (patch)
tree8012bc1563c4430966525889cf7d951b73d4d476 /gui-wm/dwl/dwl-0.3.1.ebuild
parent8f8d6a00599012882349ae6eb7f9cc86fcc6ab71 (diff)
downloadportage-overlay-47949a98e88419536175e2eca88b2b72ef06c181.tar.gz
portage-overlay-47949a98e88419536175e2eca88b2b72ef06c181.tar.bz2
portage-overlay-47949a98e88419536175e2eca88b2b72ef06c181.zip
add cage, dwl, and gentoo-sources, grapejuice symlinks
Diffstat (limited to 'gui-wm/dwl/dwl-0.3.1.ebuild')
-rw-r--r--gui-wm/dwl/dwl-0.3.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/gui-wm/dwl/dwl-0.3.1.ebuild b/gui-wm/dwl/dwl-0.3.1.ebuild
new file mode 100644
index 0000000..8438f67
--- /dev/null
+++ b/gui-wm/dwl/dwl-0.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic savedconfig toolchain-funcs desktop
+
+DESCRIPTION="dwm for Wayland"
+HOMEPAGE="https://github.com/djpohly/dwl"
+SRC_URI="https://github.com/djpohly/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0 GPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ dev-libs/libinput
+ dev-libs/wayland
+ gui-libs/wlroots:0/15[X(-)?]
+ x11-libs/libxkbcommon
+ X? ( x11-libs/libxcb )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ restore_config config.h
+}
+
+src_configure() {
+ use X && append-cppflags -DXWAYLAND
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+
+ domenu "${FILESDIR}"/dwl.desktop
+
+ einstalldocs
+
+ save_config config.h
+}