aboutsummaryrefslogtreecommitdiffstats
path: root/sys-kernel/gentoo-sources/gentoo-sources-6.1.19.ebuild
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-05-21 17:47:44 -0500
committerturret <turret@duck.com>2023-05-21 17:47:44 -0500
commit47949a98e88419536175e2eca88b2b72ef06c181 (patch)
tree8012bc1563c4430966525889cf7d951b73d4d476 /sys-kernel/gentoo-sources/gentoo-sources-6.1.19.ebuild
parent8f8d6a00599012882349ae6eb7f9cc86fcc6ab71 (diff)
downloadportage-overlay-47949a98e88419536175e2eca88b2b72ef06c181.tar.gz
portage-overlay-47949a98e88419536175e2eca88b2b72ef06c181.tar.bz2
portage-overlay-47949a98e88419536175e2eca88b2b72ef06c181.zip
add cage, dwl, and gentoo-sources, grapejuice symlinks
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-6.1.19.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-6.1.19.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-6.1.19.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-6.1.19.ebuild
new file mode 100644
index 0000000..40f2e71
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-6.1.19.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="23"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}