aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games-util/grapejuice/Manifest1
-rw-r--r--games-util/grapejuice/grapejuice-7.20.12.ebuild77
-rw-r--r--games-util/grapejuice/grapejuice-9999.ebuild77
-rw-r--r--games-util/grapejuice/metadata.xml11
4 files changed, 0 insertions, 166 deletions
diff --git a/games-util/grapejuice/Manifest b/games-util/grapejuice/Manifest
deleted file mode 100644
index 8933ce8..0000000
--- a/games-util/grapejuice/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST grapejuice-v7.20.12.tar.bz2 1106306 BLAKE2B 50d15c9f0d1adf606bd07d349e289e08a313c1ee778f5248f77104bb51dad976a35c9e2ff45f401065d934f1be2d15a5f1d71f7f21a96f0b9f4fc08ee6c28636 SHA512 23ae9dc1ca9058a8b2a72f350a78f2e87874e393a418ac474eba9e6988343186b0f0e17c37d698500b6744c90cedb55ff2c2ada29ffcbf33510de759cfdebfd4
diff --git a/games-util/grapejuice/grapejuice-7.20.12.ebuild b/games-util/grapejuice/grapejuice-7.20.12.ebuild
deleted file mode 100644
index 147b21f..0000000
--- a/games-util/grapejuice/grapejuice-7.20.12.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit xdg
-
-DESCRIPTION="A Wine+Roblox management application"
-HOMEPAGE="https://gitlab.com/brinkervii/grapejuice"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/brinkervii/grapejuice.git"
- EGIT_BRANCH="staging"
-else
- SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.tar.bz2"
- KEYWORDS="-* ~amd64"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-DEPEND="dev-libs/gobject-introspection
- dev-python/click
- dev-python/packaging
- dev-python/pip
- dev-python/psutil
- dev-python/pydantic
- dev-python/pygobject
- dev-python/requests
- dev-python/setuptools
- dev-python/unidecode
- dev-python/wheel
- dev-util/desktop-file-utils
- dev-util/gtk-update-icon-cache
- dev-vcs/git
- sys-devel/gettext
- x11-apps/mesa-progs
- x11-libs/cairo
- x11-libs/gtk+
- x11-misc/shared-mime-info
- x11-misc/xdg-user-dirs
- x11-misc/xdg-utils"
-
-RDEPEND="
- ${DEPEND}
- virtual/wine"
-
-src_unpack() {
- default
- if [[ ${PV} == *9999* ]]; then
- git-r3_src_unpack
- else
- mv "${WORKDIR}/grapejuice-v${PV}" "${S}" || die
- fi
-}
-
-src_prepare() {
- default
- sed -i \
- -e 's/"--target"/"--no-build-isolation",\n\t\t"--target"/' \
- src/grapejuice_packaging/builders/linux_package_builder.py || die
-}
-
-src_compile() {
- cd "${S}"
- export PYTHONPATH="${S}/src"
- python3 -m grapejuice_packaging linux_package || die
-}
-
-src_install() {
- export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
- tar -xf "${S}/dist/linux_package"/*.tar.gz -C "${D}" || die
- mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}" || die
- rm -r "${D}/usr/lib/python3" || die
- default
-}
diff --git a/games-util/grapejuice/grapejuice-9999.ebuild b/games-util/grapejuice/grapejuice-9999.ebuild
deleted file mode 100644
index 147b21f..0000000
--- a/games-util/grapejuice/grapejuice-9999.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit xdg
-
-DESCRIPTION="A Wine+Roblox management application"
-HOMEPAGE="https://gitlab.com/brinkervii/grapejuice"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/brinkervii/grapejuice.git"
- EGIT_BRANCH="staging"
-else
- SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.tar.bz2"
- KEYWORDS="-* ~amd64"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-DEPEND="dev-libs/gobject-introspection
- dev-python/click
- dev-python/packaging
- dev-python/pip
- dev-python/psutil
- dev-python/pydantic
- dev-python/pygobject
- dev-python/requests
- dev-python/setuptools
- dev-python/unidecode
- dev-python/wheel
- dev-util/desktop-file-utils
- dev-util/gtk-update-icon-cache
- dev-vcs/git
- sys-devel/gettext
- x11-apps/mesa-progs
- x11-libs/cairo
- x11-libs/gtk+
- x11-misc/shared-mime-info
- x11-misc/xdg-user-dirs
- x11-misc/xdg-utils"
-
-RDEPEND="
- ${DEPEND}
- virtual/wine"
-
-src_unpack() {
- default
- if [[ ${PV} == *9999* ]]; then
- git-r3_src_unpack
- else
- mv "${WORKDIR}/grapejuice-v${PV}" "${S}" || die
- fi
-}
-
-src_prepare() {
- default
- sed -i \
- -e 's/"--target"/"--no-build-isolation",\n\t\t"--target"/' \
- src/grapejuice_packaging/builders/linux_package_builder.py || die
-}
-
-src_compile() {
- cd "${S}"
- export PYTHONPATH="${S}/src"
- python3 -m grapejuice_packaging linux_package || die
-}
-
-src_install() {
- export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
- tar -xf "${S}/dist/linux_package"/*.tar.gz -C "${D}" || die
- mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}" || die
- rm -r "${D}/usr/lib/python3" || die
- default
-}
diff --git a/games-util/grapejuice/metadata.xml b/games-util/grapejuice/metadata.xml
deleted file mode 100644
index f1a0728..0000000
--- a/games-util/grapejuice/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>turret@turret.cyou</email>
- <name>turret</name>
- </maintainer>
- <upstream>
- <remote-id type="gitlab">brinkervii/grapejuice.git</remote-id>
- </upstream>
-</pkgmetadata>