aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--app-misc/ani-cli/Manifest2
-rw-r--r--app-misc/ani-cli/ani-cli-3.3.ebuild27
-rw-r--r--games-util/grapejuice/Manifest4
-rw-r--r--games-util/grapejuice/grapejuice-5.3.3.ebuild62
-rw-r--r--games-util/grapejuice/grapejuice-5.5.4.ebuild62
-rw-r--r--metadata/layout.conf1
-rw-r--r--net-im/Quaternion/Manifest2
-rw-r--r--net-im/Quaternion/Quaternion-0.0.9.4e-r1.ebuild45
-rw-r--r--profiles/repo_name1
-rw-r--r--virtual/linux-sources/Manifest1
-rw-r--r--virtual/linux-sources/linux-sources-3-r7.ebuild13
11 files changed, 220 insertions, 0 deletions
diff --git a/app-misc/ani-cli/Manifest b/app-misc/ani-cli/Manifest
new file mode 100644
index 0000000..d83b859
--- /dev/null
+++ b/app-misc/ani-cli/Manifest
@@ -0,0 +1,2 @@
+DIST ani-cli-3.3.tar.gz 121696 BLAKE2B ec5c3fab230f6015f748cbd08abcb664206a278991f78c77e7837b74a2cee9241e5b6b578e1959bba2337ad1899161ea6a0e92d0c28560e5ce7f97c8c7d12ec0 SHA512 454502d23238fb8b32382aa24ae9d05c0210d32c6e199a542bc0d9fbf10c8c2afd9d9c95d82c63b8598df6cfc325b56d429d9aa71b2e83cf77407622732bd346
+EBUILD ani-cli-3.3.ebuild 513 BLAKE2B 211a3ef3582e5f54b78e41a03f53d6e6d5dfff1515d289008bfd53da4174671a1f86444409f9915682453700e71be8301a485eb91a95362639db11e837d2b136 SHA512 3f2dba7d2bbb3ac9741eefb4ccf055106aa6634b2dc6e89c5daaadcf400c5701e786bd82eeddcfff084dcee163fceb530fb5e515f2fe46710dc8915781996855
diff --git a/app-misc/ani-cli/ani-cli-3.3.ebuild b/app-misc/ani-cli/ani-cli-3.3.ebuild
new file mode 100644
index 0000000..54b5b2b
--- /dev/null
+++ b/app-misc/ani-cli/ani-cli-3.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A cli to browse and watch anime."
+HOMEPAGE="https://github.com/pystardust/ani-cli/"
+SRC_URI="https://github.com/pystardust/$PN/archive/refs/tags/v$PV.tar.gz -> $P.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-video/mpv
+ dev-libs/openssl
+ net-misc/curl
+ media-video/ffmpeg"
+
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ dobin ani-cli
+
+}
diff --git a/games-util/grapejuice/Manifest b/games-util/grapejuice/Manifest
new file mode 100644
index 0000000..a346de7
--- /dev/null
+++ b/games-util/grapejuice/Manifest
@@ -0,0 +1,4 @@
+DIST grapejuice-v5.3.3.zip 420886 BLAKE2B 4ae54e2701d52daf84c16629e29e1800f4149eece0a1fa585e5594f93f9dab47286858d181d7ebaacd19f78f8a1ac8d86996f1a5c1e6ba7693143d122cf9a9e4 SHA512 a7da38336ba73d3acd21493f343ef86f75943998dd32a9d4ca3b819aa641afe1c888607f229306751c5ccca03f1e51116130747e8aaec2b8d93b51d512f43907
+DIST grapejuice-v5.5.4.zip 434211 BLAKE2B 6bd18dd3702eb3ac738e012508b6ed0dd686ca75a4913fa5a694cf74d00c5ae59a4e5e924436654058acd7deeab7b637f010cdc11ada4126094b0e8bc50e50ad SHA512 4244173e1edcae8c8b58cdd78e08daa860260086052aba3d2c49292291d5199b515acfc4a12fb4f7662812dd20e6f8eedfb48f1c52fee66367d89064d2fa5533
+EBUILD grapejuice-5.3.3.ebuild 1626 BLAKE2B f6c81a0fb437cd4d1e7f68e25f1e24148ace8f12e6d005a7cfc435cd8725d59951623f72f4ecc1cd56a8d60c510204be7ab57d4795361b4db6598ae70451c23a SHA512 dd8b69437b6eb0b42f44ba801d21a9f3e200f46f8b4a5640aeb53553f3c3e221c4bdf1d3de10e9a82e1a133fc313fcde7b6c7d1ab7f85038baa02541b68fdd55
+EBUILD grapejuice-5.5.4.ebuild 1626 BLAKE2B f6c81a0fb437cd4d1e7f68e25f1e24148ace8f12e6d005a7cfc435cd8725d59951623f72f4ecc1cd56a8d60c510204be7ab57d4795361b4db6598ae70451c23a SHA512 dd8b69437b6eb0b42f44ba801d21a9f3e200f46f8b4a5640aeb53553f3c3e221c4bdf1d3de10e9a82e1a133fc313fcde7b6c7d1ab7f85038baa02541b68fdd55
diff --git a/games-util/grapejuice/grapejuice-5.3.3.ebuild b/games-util/grapejuice/grapejuice-5.3.3.ebuild
new file mode 100644
index 0000000..c490dec
--- /dev/null
+++ b/games-util/grapejuice/grapejuice-5.3.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="A Wine+Roblox management application"
+HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
+SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+DEPEND="app-arch/unzip
+ dev-libs/gobject-introspection
+ dev-libs/openssl[abi_x86_32]
+ dev-python/click
+ dev-python/pygobject
+ dev-python/packaging
+ dev-python/pip
+ dev-python/psutil
+ dev-python/requests
+ dev-python/setuptools
+ dev-python/unidecode
+ dev-util/desktop-file-utils
+ dev-util/gtk-update-icon-cache
+ media-libs/libpulse[abi_x86_32]
+ media-libs/mesa
+ net-libs/gnutls[abi_x86_32]
+ x11-libs/cairo
+ x11-libs/gtk+
+ x11-misc/shared-mime-info
+ x11-misc/xdg-user-dirs
+ x11-misc/xdg-utils"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv ${WORKDIR}/grapejuice-v${PV} ${S}
+}
+
+src_compile() {
+ cd ${S}
+ export PYTHONPATH="${S}/src"
+ python3 -m grapejuice_packaging linux_package
+}
+
+src_install() {
+ export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
+ tar -xf ${S}/dist/linux_package/*.tar.gz -C ${D}
+ mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}"
+ rm -r "${D}/usr/lib/python3"
+ default
+}
+
+pkg_postinst() {
+ optfeature "Wine is required to run Roblox, but left out of depends to let the user decide on custom builds" app-emulation/wine
+ optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
+}
diff --git a/games-util/grapejuice/grapejuice-5.5.4.ebuild b/games-util/grapejuice/grapejuice-5.5.4.ebuild
new file mode 100644
index 0000000..c490dec
--- /dev/null
+++ b/games-util/grapejuice/grapejuice-5.5.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="A Wine+Roblox management application"
+HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
+SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+DEPEND="app-arch/unzip
+ dev-libs/gobject-introspection
+ dev-libs/openssl[abi_x86_32]
+ dev-python/click
+ dev-python/pygobject
+ dev-python/packaging
+ dev-python/pip
+ dev-python/psutil
+ dev-python/requests
+ dev-python/setuptools
+ dev-python/unidecode
+ dev-util/desktop-file-utils
+ dev-util/gtk-update-icon-cache
+ media-libs/libpulse[abi_x86_32]
+ media-libs/mesa
+ net-libs/gnutls[abi_x86_32]
+ x11-libs/cairo
+ x11-libs/gtk+
+ x11-misc/shared-mime-info
+ x11-misc/xdg-user-dirs
+ x11-misc/xdg-utils"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv ${WORKDIR}/grapejuice-v${PV} ${S}
+}
+
+src_compile() {
+ cd ${S}
+ export PYTHONPATH="${S}/src"
+ python3 -m grapejuice_packaging linux_package
+}
+
+src_install() {
+ export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
+ tar -xf ${S}/dist/linux_package/*.tar.gz -C ${D}
+ mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}"
+ rm -r "${D}/usr/lib/python3"
+ default
+}
+
+pkg_postinst() {
+ optfeature "Wine is required to run Roblox, but left out of depends to let the user decide on custom builds" app-emulation/wine
+ optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
+}
diff --git a/metadata/layout.conf b/metadata/layout.conf
new file mode 100644
index 0000000..d43e61c
--- /dev/null
+++ b/metadata/layout.conf
@@ -0,0 +1 @@
+masters = gentoo
diff --git a/net-im/Quaternion/Manifest b/net-im/Quaternion/Manifest
new file mode 100644
index 0000000..5d8e30e
--- /dev/null
+++ b/net-im/Quaternion/Manifest
@@ -0,0 +1,2 @@
+DIST Quaternion-0.0.9.4e.tar.gz 999309 BLAKE2B 7f1763fa5340f11f7ed5aee0fa7e3f91764cad7f248ba1be26472866d7cf2b78e2144d0719a89a9b78503f744ca424c1eb2d3dd91f4c6677ea23255166466be8 SHA512 5478892b7dce96a60f1429ee6dff9dd0b4fbb89bf45ecc2e499ee90f615af4de12d1de0002804420a85a21a6ba533e4799c94d2411067cb7d7aacca183d9d981
+EBUILD Quaternion-0.0.9.4e-r1.ebuild 1119 BLAKE2B 37e9274e726f73c23624e097cc9eca57a8024df26ad2ef0ada6cb2efb5820aeecbb9309443aa6cdaae339380bc073d96a4f0f146c2f34297f8cd57ae515f1f9d SHA512 da0c56292a2489dd1d2a8f8a60292239b31e3918f58648a630d5f94d07a154d663ea081183cce555729c9188c08cf10fd59911864d07e9d172695cb1196d9bfd
diff --git a/net-im/Quaternion/Quaternion-0.0.9.4e-r1.ebuild b/net-im/Quaternion/Quaternion-0.0.9.4e-r1.ebuild
new file mode 100644
index 0000000..3162397
--- /dev/null
+++ b/net-im/Quaternion/Quaternion-0.0.9.4e-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A Qt5-based IM client for the Matrix protocol"
+HOMEPAGE="https://github.com/QMatrixClient/Quaternion https://matrix.org/docs/projects/client/quaternion.html"
+SRC_URI="https://github.com/QMatrixClient/Quaternion/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64"
+IUSE="+keychain"
+RESTRICT="mirror"
+
+DEPEND="
+ dev-qt/qtwidgets:5=
+ dev-qt/qtnetwork:5=
+ dev-qt/qtquickcontrols:5=
+ dev-qt/qtquickcontrols2:5=
+ dev-qt/qtscript:5=
+ dev-qt/qtgui:5=
+ dev-qt/linguist-tools:5=
+ dev-qt/qtmultimedia:5=
+ >=net-libs/libqmatrixclient-0.5.1:=
+ keychain? ( dev-libs/qtkeychain:= )
+"
+
+src_prepare() {
+ # I wouldn't be surprised that Qt on a Ubuntu PPA is broken
+ # https://github.com/quotient-im/Quaternion/pull/484/files#r256167611
+ sed -i 's/Multimedia DBus)/Multimedia)/' CMakeLists.txt || die "Failed removing hard-dep on QtDbus"
+
+ default
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_KEYCHAIN=$(usex keychain)
+ )
+
+ cmake_src_configure
+}
diff --git a/profiles/repo_name b/profiles/repo_name
new file mode 100644
index 0000000..4083037
--- /dev/null
+++ b/profiles/repo_name
@@ -0,0 +1 @@
+local
diff --git a/virtual/linux-sources/Manifest b/virtual/linux-sources/Manifest
new file mode 100644
index 0000000..3951ef1
--- /dev/null
+++ b/virtual/linux-sources/Manifest
@@ -0,0 +1 @@
+EBUILD linux-sources-3-r7.ebuild 330 BLAKE2B ddcf62be7bea849a186cdd6f6004e6a3f327b2d220e628224e11edc0f0767745d6c70be047984048e992bf5f428f53f80c5dd777bf395285a10a515245a11e3d SHA512 fc93b37f28860c8aa6609d1dedcb3d3732b1bc1ef92449382d25b00dbf9e327571bdf034a29a04637a0e471d828d457515f35cf68ea8275ceae04d0a85494c04
diff --git a/virtual/linux-sources/linux-sources-3-r7.ebuild b/virtual/linux-sources/linux-sources-3-r7.ebuild
new file mode 100644
index 0000000..d5004f4
--- /dev/null
+++ b/virtual/linux-sources/linux-sources-3-r7.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Virtual for Linux kernel sources"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="firmware"
+
+RDEPEND="
+ firmware? ( sys-kernel/linux-firmware )
+"