aboutsummaryrefslogtreecommitdiffstats
path: root/games-util/grapejuice/grapejuice-7.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/grapejuice/grapejuice-7.7.2.ebuild')
-rw-r--r--[l---------]games-util/grapejuice/grapejuice-7.7.2.ebuild55
1 files changed, 54 insertions, 1 deletions
diff --git a/games-util/grapejuice/grapejuice-7.7.2.ebuild b/games-util/grapejuice/grapejuice-7.7.2.ebuild
index f559fa7..a96258c 120000..100644
--- a/games-util/grapejuice/grapejuice-7.7.2.ebuild
+++ b/games-util/grapejuice/grapejuice-7.7.2.ebuild
@@ -1 +1,54 @@
-grapejuice-5.3.3.ebuild \ No newline at end of file
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg optfeature
+
+DESCRIPTION="A Wine+Roblox management application"
+HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
+SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86_64"
+RESTRICT="mirror"
+
+DEPEND="sys-devel/gettext
+ dev-vcs/git
+ dev-python/pip
+ x11-libs/cairo
+ x11-libs/gtk+
+ dev-libs/gobject-introspection
+ dev-util/desktop-file-utils
+ x11-misc/xdg-utils
+ x11-misc/xdg-user-dirs
+ dev-util/gtk-update-icon-cache
+ x11-misc/shared-mime-info
+ x11-apps/mesa-progs"
+RDEPEND="
+ ${DEPEND}
+ virtual/wine"
+
+src_unpack() {
+ default
+ mv "${WORKDIR}/grapejuice-v${PV}" "${S}"
+}
+
+src_compile() {
+ cd "${S}"
+ export PYTHONPATH="${S}/src"
+ python3 -m grapejuice_packaging linux_package
+}
+
+src_install() {
+ export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
+ tar -xf "${S}/dist/linux_package/*.tar.gz" -C "${D}"
+ mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}"
+ rm -r "${D}/usr/lib/python3"
+ default
+}
+
+pkg_postinst() {
+ optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
+}