aboutsummaryrefslogtreecommitdiffstats
path: root/gui-wm/cage/cage-0.1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-wm/cage/cage-0.1.4.ebuild')
-rw-r--r--gui-wm/cage/cage-0.1.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/gui-wm/cage/cage-0.1.4.ebuild b/gui-wm/cage/cage-0.1.4.ebuild
new file mode 100644
index 0000000..ada7de6
--- /dev/null
+++ b/gui-wm/cage/cage-0.1.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ "${PV}" == 9999 ]]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Hjdskes/cage"
+else
+ SRC_URI="https://github.com/Hjdskes/cage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A Wayland kiosk"
+HOMEPAGE="https://www.hjdskes.nl/projects/cage/ https://github.com/Hjdskes/cage"
+LICENSE="MIT"
+SLOT="0"
+RESTRICT="mirror"
+
+IUSE="X"
+
+RDEPEND="
+ >=gui-libs/wlroots-0.14[X?]
+ x11-libs/libxkbcommon[X?]
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ meson_src_configure $(meson_use X xwayland)
+}