aboutsummaryrefslogtreecommitdiffstats
path: root/gui-wm/dwl
diff options
context:
space:
mode:
Diffstat (limited to 'gui-wm/dwl')
-rw-r--r--gui-wm/dwl/Manifest6
-rw-r--r--gui-wm/dwl/dwl-0.4-r1.ebuild81
-rw-r--r--gui-wm/dwl/dwl-9999-r1.ebuild80
-rw-r--r--gui-wm/dwl/dwl-9999.ebuild80
-rw-r--r--gui-wm/dwl/files/dwl.desktop7
-rw-r--r--gui-wm/dwl/metadata.xml19
6 files changed, 0 insertions, 273 deletions
diff --git a/gui-wm/dwl/Manifest b/gui-wm/dwl/Manifest
deleted file mode 100644
index 44e0935..0000000
--- a/gui-wm/dwl/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-AUX dwl.desktop 102 BLAKE2B edc678ce6265ccf4fdfc19b6b7b56c38bfe85ab2ea3e2fe5d156b98b7eb736cb6709dcff824c9942707e64dd0a4b6feffcf003d96899e95a4956ebba0cf1557b SHA512 32e3314438c473e9259f6e13c28fb5c70c9ee9f112964e34aa09a7fdbdb99067e51336dba16bff75557ee90aee0352aa4504f47ca7d20a082471d75fc7cb2e3c
-DIST dwl-0.4.tar.gz 55527 BLAKE2B a4c6d763574f2bf88db959a4730447874de61d4d868d12285feebc121204c4dbda82ab3cfef791999e138898daa5564d295d4943aff015d91d62d9c9ade6d005 SHA512 6e15e05001e6469d13bef2d532980585d57de55c8feb461a7c25a76d7cdaee022785485faca02cd9d1214457fbeb1bec0eb652700ba0ddccca4aa780df0046b2
-EBUILD dwl-0.4-r1.ebuild 1436 BLAKE2B 6ed4385e8ce5bfcb70910e0a9b1c64179694e96f260c768b13398154627798f7cf2632bc6dd2511eb41033942f2073173b345bf82888dd5c1b64e12cf4217582 SHA512 413a2133474bba09e5bb7fc2a6f852f8a0b680a44d3b5abd1c5de7609b42c7b134a41227378048d3dcc1737770635cb692a064dafc2ebfecf8bb10c434233f58
-EBUILD dwl-9999-r1.ebuild 1418 BLAKE2B 5a940c0ffb2e745b038f4402ee4496bd61fd661c4ff44ff24ce9a5fe05b00e998ac9a06e930ce5bd7a4df25ecaf28f9e8c138bda3efafd46398bfa5b80adeee0 SHA512 80d285ae8e250a8965ec9ebbdc72af7055c41c50ae7bd1ac3ac0449305c0b1f672c440ee7afc133c2046f9e9d1b8bb743dad5ad607feb62d506be2d86fbb7397
-EBUILD dwl-9999.ebuild 1418 BLAKE2B 5a940c0ffb2e745b038f4402ee4496bd61fd661c4ff44ff24ce9a5fe05b00e998ac9a06e930ce5bd7a4df25ecaf28f9e8c138bda3efafd46398bfa5b80adeee0 SHA512 80d285ae8e250a8965ec9ebbdc72af7055c41c50ae7bd1ac3ac0449305c0b1f672c440ee7afc133c2046f9e9d1b8bb743dad5ad607feb62d506be2d86fbb7397
-MISC metadata.xml 641 BLAKE2B 744e2c8c19b0147417d14bfb78e139419474d0915562f5e87a9b27f2943ae4f20f7cb598359ad8bb4524cdfcad9ddbb760e605b1e1a419240bd515a00781bae7 SHA512 c371abca532be2ff13a8678d0f8a9c0e5ea363f5a1ce6c968f4980290668f9d356174d53ee660040c071b54d157e0e9e5c1bb76e0ff408ade763eda3fd060e4b
diff --git a/gui-wm/dwl/dwl-0.4-r1.ebuild b/gui-wm/dwl/dwl-0.4-r1.ebuild
deleted file mode 100644
index 6bf6eeb..0000000
--- a/gui-wm/dwl/dwl-0.4-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic savedconfig toolchain-funcs
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/djpohly/dwl"
- inherit git-r3
-
- # 9999-r0: main (latest wlroots release)
- # 9999-r1: wlroots-next (wlroots-9999)
- case ${PVR} in
- 9999)
- EGIT_BRANCH=main
- WLROOTS_SLOT="0/16"
- ;;
- 9999-r1)
- EGIT_BRANCH=wlroots-next
- WLROOTS_SLOT="0/9999"
- ;;
- esac
-else
- WLROOTS_SLOT="0/16"
- SRC_URI="https://github.com/djpohly/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="dwm for Wayland"
-HOMEPAGE="https://github.com/djpohly/dwl"
-
-RESTRICT="mirror"
-LICENSE="CC0-1.0 GPL-3 MIT"
-SLOT="0"
-IUSE="X"
-
-RDEPEND="
- dev-libs/libinput:=
- dev-libs/wayland
- gui-libs/wlroots:${WLROOTS_SLOT}[X(-)?]
- x11-libs/libxkbcommon
- X? (
- x11-libs/libxcb:=
- x11-libs/xcb-util-wm
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-libs/wayland-protocols
- dev-util/wayland-scanner
- virtual/pkgconfig
-"
-
-src_prepare() {
- restore_config config.h
-
- default
-}
-
-src_configure() {
- sed -i "s:/local::g" config.mk || die
-
- sed -i "s:pkg-config:$(tc-getPKG_CONFIG):g" config.mk || die
-
- tc-export CC
-
- if use X; then
- append-cppflags '-DXWAYLAND'
- append-libs '-lxcb' '-lxcb-icccm'
- fi
-}
-
-src_install() {
- default
-
- insinto /usr/share/wayland-sessions
- doins "${FILESDIR}"/dwl.desktop
-
- save_config config.h
-}
diff --git a/gui-wm/dwl/dwl-9999-r1.ebuild b/gui-wm/dwl/dwl-9999-r1.ebuild
deleted file mode 100644
index a7cb086..0000000
--- a/gui-wm/dwl/dwl-9999-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic savedconfig toolchain-funcs
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/djpohly/dwl"
- inherit git-r3
-
- # 9999-r0: main (latest wlroots release)
- # 9999-r1: wlroots-next (wlroots-9999)
- case ${PVR} in
- 9999)
- EGIT_BRANCH=main
- WLROOTS_SLOT="0/16"
- ;;
- 9999-r1)
- EGIT_BRANCH=wlroots-next
- WLROOTS_SLOT="0/9999"
- ;;
- esac
-else
- WLROOTS_SLOT="0/16"
- SRC_URI="https://github.com/djpohly/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="dwm for Wayland"
-HOMEPAGE="https://github.com/djpohly/dwl"
-
-LICENSE="CC0-1.0 GPL-3 MIT"
-SLOT="0"
-IUSE="X"
-
-RDEPEND="
- dev-libs/libinput:=
- dev-libs/wayland
- gui-libs/wlroots:${WLROOTS_SLOT}[X(-)?]
- x11-libs/libxkbcommon
- X? (
- x11-libs/libxcb:=
- x11-libs/xcb-util-wm
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-libs/wayland-protocols
- dev-util/wayland-scanner
- virtual/pkgconfig
-"
-
-src_prepare() {
- restore_config config.h
-
- default
-}
-
-src_configure() {
- sed -i "s:/local::g" config.mk || die
-
- sed -i "s:pkg-config:$(tc-getPKG_CONFIG):g" config.mk || die
-
- tc-export CC
-
- if use X; then
- append-cppflags '-DXWAYLAND'
- append-libs '-lxcb' '-lxcb-icccm'
- fi
-}
-
-src_install() {
- default
-
- insinto /usr/share/wayland-sessions
- doins "${FILESDIR}"/dwl.desktop
-
- save_config config.h
-}
diff --git a/gui-wm/dwl/dwl-9999.ebuild b/gui-wm/dwl/dwl-9999.ebuild
deleted file mode 100644
index a7cb086..0000000
--- a/gui-wm/dwl/dwl-9999.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic savedconfig toolchain-funcs
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/djpohly/dwl"
- inherit git-r3
-
- # 9999-r0: main (latest wlroots release)
- # 9999-r1: wlroots-next (wlroots-9999)
- case ${PVR} in
- 9999)
- EGIT_BRANCH=main
- WLROOTS_SLOT="0/16"
- ;;
- 9999-r1)
- EGIT_BRANCH=wlroots-next
- WLROOTS_SLOT="0/9999"
- ;;
- esac
-else
- WLROOTS_SLOT="0/16"
- SRC_URI="https://github.com/djpohly/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="dwm for Wayland"
-HOMEPAGE="https://github.com/djpohly/dwl"
-
-LICENSE="CC0-1.0 GPL-3 MIT"
-SLOT="0"
-IUSE="X"
-
-RDEPEND="
- dev-libs/libinput:=
- dev-libs/wayland
- gui-libs/wlroots:${WLROOTS_SLOT}[X(-)?]
- x11-libs/libxkbcommon
- X? (
- x11-libs/libxcb:=
- x11-libs/xcb-util-wm
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-libs/wayland-protocols
- dev-util/wayland-scanner
- virtual/pkgconfig
-"
-
-src_prepare() {
- restore_config config.h
-
- default
-}
-
-src_configure() {
- sed -i "s:/local::g" config.mk || die
-
- sed -i "s:pkg-config:$(tc-getPKG_CONFIG):g" config.mk || die
-
- tc-export CC
-
- if use X; then
- append-cppflags '-DXWAYLAND'
- append-libs '-lxcb' '-lxcb-icccm'
- fi
-}
-
-src_install() {
- default
-
- insinto /usr/share/wayland-sessions
- doins "${FILESDIR}"/dwl.desktop
-
- save_config config.h
-}
diff --git a/gui-wm/dwl/files/dwl.desktop b/gui-wm/dwl/files/dwl.desktop
deleted file mode 100644
index 343f5d4..0000000
--- a/gui-wm/dwl/files/dwl.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Name=dwl
-Comment=dwm for Wayland
-Exec=/usr/bin/dwl
-TryExec=dwl
-Icon=
-Type=Application
diff --git a/gui-wm/dwl/metadata.xml b/gui-wm/dwl/metadata.xml
deleted file mode 100644
index edea311..0000000
--- a/gui-wm/dwl/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>leohdz172@proton.me</email>
- <name>Leonardo Hernández Hernández</name>
- </maintainer>
- <maintainer type="person">
- <email>svdm-gentoo@protonmail.com</email>
- <name>Simon van der Maas</name>
- </maintainer>
- <maintainer type="person">
- <email>efe.izbudak@metu.edu.tr</email>
- <name>Efe İzbudak</name>
- </maintainer>
- <upstream>
- <remote-id type="github">djpohly/dwl</remote-id>
- </upstream>
-</pkgmetadata>