aboutsummaryrefslogtreecommitdiffstats
path: root/app-misc/glow/glow-1.4.1.ebuild
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-06-12 18:46:46 -0500
committerturret <turret@duck.com>2023-06-12 18:46:46 -0500
commitfeff426ea7a20b0e968fd214dfd377f398ff7ad2 (patch)
treea3e923e94ce46e1af5749732d7687baac9c0603f /app-misc/glow/glow-1.4.1.ebuild
parent8e7ddc68df7b7104b7b40b6f20bd858097d7e995 (diff)
downloadportage-overlay-feff426ea7a20b0e968fd214dfd377f398ff7ad2.tar.gz
portage-overlay-feff426ea7a20b0e968fd214dfd377f398ff7ad2.tar.bz2
portage-overlay-feff426ea7a20b0e968fd214dfd377f398ff7ad2.zip
app-misc/glow: new pkg, restrict=mirror
Diffstat (limited to 'app-misc/glow/glow-1.4.1.ebuild')
-rw-r--r--app-misc/glow/glow-1.4.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-misc/glow/glow-1.4.1.ebuild b/app-misc/glow/glow-1.4.1.ebuild
new file mode 100644
index 0000000..8e4ba5f
--- /dev/null
+++ b/app-misc/glow/glow-1.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Render markdown on the CLI, with pizzazz!"
+HOMEPAGE="https://github.com/charmbracelet/glow"
+SRC_URI="
+ https://github.com/charmbracelet/glow/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/telans/distfiles/raw/main/${CATEGORY}/${PN}/${P}-deps.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD-2 BSD MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+src_install() {
+ einstalldocs
+ dobin glow
+}