aboutsummaryrefslogtreecommitdiffstats
path: root/app-misc/glow/glow-1.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/glow/glow-1.4.1.ebuild')
-rw-r--r--app-misc/glow/glow-1.4.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-misc/glow/glow-1.4.1.ebuild b/app-misc/glow/glow-1.4.1.ebuild
new file mode 100644
index 0000000..8e4ba5f
--- /dev/null
+++ b/app-misc/glow/glow-1.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Render markdown on the CLI, with pizzazz!"
+HOMEPAGE="https://github.com/charmbracelet/glow"
+SRC_URI="
+ https://github.com/charmbracelet/glow/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/telans/distfiles/raw/main/${CATEGORY}/${PN}/${P}-deps.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD-2 BSD MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+src_install() {
+ einstalldocs
+ dobin glow
+}