aboutsummaryrefslogtreecommitdiffstats
path: root/dev-python/pycryptodomex/pycryptodomex-3.18.0x.ebuild
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-06-30 23:07:08 -0500
committerturret <turret@duck.com>2023-06-30 23:07:08 -0500
commit36cdca2ab7c038bba12a9cb5140c0d0276b63972 (patch)
tree5536fbc147193849039c6e9916c670341866b2b8 /dev-python/pycryptodomex/pycryptodomex-3.18.0x.ebuild
parent9926cdc47b2177dad000ea5bae4b7ef85ef6f880 (diff)
downloadportage-overlay-36cdca2ab7c038bba12a9cb5140c0d0276b63972.tar.gz
portage-overlay-36cdca2ab7c038bba12a9cb5140c0d0276b63972.tar.bz2
portage-overlay-36cdca2ab7c038bba12a9cb5140c0d0276b63972.zip
app-misc/animdl: reference correct package, new pkg cryptodomex
Diffstat (limited to 'dev-python/pycryptodomex/pycryptodomex-3.18.0x.ebuild')
-rw-r--r--dev-python/pycryptodomex/pycryptodomex-3.18.0x.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pycryptodomex/pycryptodomex-3.18.0x.ebuild b/dev-python/pycryptodomex/pycryptodomex-3.18.0x.ebuild
new file mode 100644
index 0000000..1f4862c
--- /dev/null
+++ b/dev-python/pycryptodomex/pycryptodomex-3.18.0x.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_11 )
+inherit distutils-r1
+
+DESCRIPTION="Python package of low-level cryptographic primitives"
+HOMEPAGE="https://github.com/Legrandin/pycryptodome"
+
+if [[ "${PV}" == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Legrandin/pycryptodome.git"
+ EGIT_BRANCH="pycryptodomex"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Legrandin/pycryptodome/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pip"
+
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv "pycryptodome-${PV}" "${P}" || die
+}