aboutsummaryrefslogtreecommitdiffstats
path: root/games-action
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-06-27 10:16:14 -0500
committerturret <turret@duck.com>2023-06-27 10:16:14 -0500
commit0907a97b8e17a95ba1521e94bc7fcf17e9ff64c9 (patch)
treeb11ec55d4c8e7854dfdf8c2416dd07d4b2ed7f99 /games-action
parent0c90ec29a55ed5babc9ebbe485ef113c4bbddddc (diff)
downloadportage-overlay-0907a97b8e17a95ba1521e94bc7fcf17e9ff64c9.tar.gz
portage-overlay-0907a97b8e17a95ba1521e94bc7fcf17e9ff64c9.tar.bz2
portage-overlay-0907a97b8e17a95ba1521e94bc7fcf17e9ff64c9.zip
games-action/portablemc-3.3.1: new package
Diffstat (limited to 'games-action')
-rw-r--r--games-action/portablemc/Manifest3
-rw-r--r--games-action/portablemc/metadata.xml11
-rw-r--r--games-action/portablemc/portablemc-3.3.1.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/games-action/portablemc/Manifest b/games-action/portablemc/Manifest
new file mode 100644
index 0000000..e338ea9
--- /dev/null
+++ b/games-action/portablemc/Manifest
@@ -0,0 +1,3 @@
+DIST portablemc-3.3.1.tar.gz 3127408 BLAKE2B 25f4898d23ae3122d135be65065d358fa4554cb62daca56c999d1ce2d2e2ad47710c3f6546301730d38e6b646e818a72e351aa8d7de29962c9af97d3a0fa7327 SHA512 6ddc1e9a94af829e7c9e039d1fcbbf24887f3861ba199ca71d18808426c56919dcf986c35956d7d2e4fbd1f6ba7448ed255eb91201ba2b0e28a9c085b0ba93cd
+EBUILD portablemc-3.3.1.ebuild 795 BLAKE2B 2aa2fce8b545c0f887871faf44a4fdd7ccb193db5df58b56782b0944c5fd40f85168ca7d556f8677d7bc062542f7bb7cfff67e8033b64a8e749fd8e8a8b9595b SHA512 bebcf140abc91bb72d03edf6f199e18106fe01ef22acbbcd96eb631c25c1978122e33f73ceff9b6dcaf493844e25cfabdf75ae8918cf3ad62dd90c529b18590c
+MISC metadata.xml 358 BLAKE2B 5e594853aed3c5658a530f880214253a17ed1f2a7f90024da06fca3c956aeb4ba8482586079b8fdaec2600303a11f4e9410f02d363008c9b9cce91242c1769af SHA512 3b10c2701398ef84d1b70ab56762c31905893ec5f22f519b6e3f0a64090840678d97fedd1846551838bf4e481e254963419d74f0be89d1d4104497d4d7f01339
diff --git a/games-action/portablemc/metadata.xml b/games-action/portablemc/metadata.xml
new file mode 100644
index 0000000..a8dd215
--- /dev/null
+++ b/games-action/portablemc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>turret@turret.cyou</email>
+ <name>turret</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mindstorm38/portablemc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/portablemc/portablemc-3.3.1.ebuild b/games-action/portablemc/portablemc-3.3.1.ebuild
new file mode 100644
index 0000000..1f9b3c2
--- /dev/null
+++ b/games-action/portablemc/portablemc-3.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_11 )
+inherit distutils-r1
+
+DESCRIPTION="An easy-to-use and extensible Python CLI Minecraft launcher with compatability!"
+HOMEPAGE="https://github.com/mindstorm38/portablemc"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/mindstorm38/portablemc.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/mindstorm38/portablemc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pip
+ dev-python/poetry-core"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv "${WORKDIR}/${P}/src/core/"* "${S}" || die
+}