aboutsummaryrefslogtreecommitdiffstats
path: root/games-util
diff options
context:
space:
mode:
authorturret <turret@duck.com>2023-05-21 17:47:44 -0500
committerturret <turret@duck.com>2023-05-21 17:47:44 -0500
commit47949a98e88419536175e2eca88b2b72ef06c181 (patch)
tree8012bc1563c4430966525889cf7d951b73d4d476 /games-util
parent8f8d6a00599012882349ae6eb7f9cc86fcc6ab71 (diff)
downloadportage-overlay-47949a98e88419536175e2eca88b2b72ef06c181.tar.gz
portage-overlay-47949a98e88419536175e2eca88b2b72ef06c181.tar.bz2
portage-overlay-47949a98e88419536175e2eca88b2b72ef06c181.zip
add cage, dwl, and gentoo-sources, grapejuice symlinks
Diffstat (limited to 'games-util')
l---------[-rw-r--r--]games-util/grapejuice/grapejuice-5.5.4.ebuild63
l---------[-rw-r--r--]games-util/grapejuice/grapejuice-7.2.0.ebuild63
l---------[-rw-r--r--]games-util/grapejuice/grapejuice-7.2.1.ebuild63
l---------[-rw-r--r--]games-util/grapejuice/grapejuice-7.5.1.ebuild63
l---------[-rw-r--r--]games-util/grapejuice/grapejuice-7.6.2.ebuild63
l---------[-rw-r--r--]games-util/grapejuice/grapejuice-7.7.2.ebuild63
l---------[-rw-r--r--]games-util/grapejuice/grapejuice-7.8.2.ebuild63
l---------[-rw-r--r--]games-util/grapejuice/grapejuice-7.8.3.ebuild63
8 files changed, 8 insertions, 496 deletions
diff --git a/games-util/grapejuice/grapejuice-5.5.4.ebuild b/games-util/grapejuice/grapejuice-5.5.4.ebuild
index c490dec..f559fa7 100644..120000
--- a/games-util/grapejuice/grapejuice-5.5.4.ebuild
+++ b/games-util/grapejuice/grapejuice-5.5.4.ebuild
@@ -1,62 +1 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit xdg
-
-DESCRIPTION="A Wine+Roblox management application"
-HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
-SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="mirror"
-
-DEPEND="app-arch/unzip
- dev-libs/gobject-introspection
- dev-libs/openssl[abi_x86_32]
- dev-python/click
- dev-python/pygobject
- dev-python/packaging
- dev-python/pip
- dev-python/psutil
- dev-python/requests
- dev-python/setuptools
- dev-python/unidecode
- dev-util/desktop-file-utils
- dev-util/gtk-update-icon-cache
- media-libs/libpulse[abi_x86_32]
- media-libs/mesa
- net-libs/gnutls[abi_x86_32]
- x11-libs/cairo
- x11-libs/gtk+
- x11-misc/shared-mime-info
- x11-misc/xdg-user-dirs
- x11-misc/xdg-utils"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- default
- mv ${WORKDIR}/grapejuice-v${PV} ${S}
-}
-
-src_compile() {
- cd ${S}
- export PYTHONPATH="${S}/src"
- python3 -m grapejuice_packaging linux_package
-}
-
-src_install() {
- export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
- tar -xf ${S}/dist/linux_package/*.tar.gz -C ${D}
- mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}"
- rm -r "${D}/usr/lib/python3"
- default
-}
-
-pkg_postinst() {
- optfeature "Wine is required to run Roblox, but left out of depends to let the user decide on custom builds" app-emulation/wine
- optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
-}
+grapejuice-5.3.3.ebuild \ No newline at end of file
diff --git a/games-util/grapejuice/grapejuice-7.2.0.ebuild b/games-util/grapejuice/grapejuice-7.2.0.ebuild
index c490dec..f559fa7 100644..120000
--- a/games-util/grapejuice/grapejuice-7.2.0.ebuild
+++ b/games-util/grapejuice/grapejuice-7.2.0.ebuild
@@ -1,62 +1 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit xdg
-
-DESCRIPTION="A Wine+Roblox management application"
-HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
-SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="mirror"
-
-DEPEND="app-arch/unzip
- dev-libs/gobject-introspection
- dev-libs/openssl[abi_x86_32]
- dev-python/click
- dev-python/pygobject
- dev-python/packaging
- dev-python/pip
- dev-python/psutil
- dev-python/requests
- dev-python/setuptools
- dev-python/unidecode
- dev-util/desktop-file-utils
- dev-util/gtk-update-icon-cache
- media-libs/libpulse[abi_x86_32]
- media-libs/mesa
- net-libs/gnutls[abi_x86_32]
- x11-libs/cairo
- x11-libs/gtk+
- x11-misc/shared-mime-info
- x11-misc/xdg-user-dirs
- x11-misc/xdg-utils"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- default
- mv ${WORKDIR}/grapejuice-v${PV} ${S}
-}
-
-src_compile() {
- cd ${S}
- export PYTHONPATH="${S}/src"
- python3 -m grapejuice_packaging linux_package
-}
-
-src_install() {
- export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
- tar -xf ${S}/dist/linux_package/*.tar.gz -C ${D}
- mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}"
- rm -r "${D}/usr/lib/python3"
- default
-}
-
-pkg_postinst() {
- optfeature "Wine is required to run Roblox, but left out of depends to let the user decide on custom builds" app-emulation/wine
- optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
-}
+grapejuice-5.3.3.ebuild \ No newline at end of file
diff --git a/games-util/grapejuice/grapejuice-7.2.1.ebuild b/games-util/grapejuice/grapejuice-7.2.1.ebuild
index c490dec..f559fa7 100644..120000
--- a/games-util/grapejuice/grapejuice-7.2.1.ebuild
+++ b/games-util/grapejuice/grapejuice-7.2.1.ebuild
@@ -1,62 +1 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit xdg
-
-DESCRIPTION="A Wine+Roblox management application"
-HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
-SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="mirror"
-
-DEPEND="app-arch/unzip
- dev-libs/gobject-introspection
- dev-libs/openssl[abi_x86_32]
- dev-python/click
- dev-python/pygobject
- dev-python/packaging
- dev-python/pip
- dev-python/psutil
- dev-python/requests
- dev-python/setuptools
- dev-python/unidecode
- dev-util/desktop-file-utils
- dev-util/gtk-update-icon-cache
- media-libs/libpulse[abi_x86_32]
- media-libs/mesa
- net-libs/gnutls[abi_x86_32]
- x11-libs/cairo
- x11-libs/gtk+
- x11-misc/shared-mime-info
- x11-misc/xdg-user-dirs
- x11-misc/xdg-utils"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- default
- mv ${WORKDIR}/grapejuice-v${PV} ${S}
-}
-
-src_compile() {
- cd ${S}
- export PYTHONPATH="${S}/src"
- python3 -m grapejuice_packaging linux_package
-}
-
-src_install() {
- export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
- tar -xf ${S}/dist/linux_package/*.tar.gz -C ${D}
- mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}"
- rm -r "${D}/usr/lib/python3"
- default
-}
-
-pkg_postinst() {
- optfeature "Wine is required to run Roblox, but left out of depends to let the user decide on custom builds" app-emulation/wine
- optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
-}
+grapejuice-5.3.3.ebuild \ No newline at end of file
diff --git a/games-util/grapejuice/grapejuice-7.5.1.ebuild b/games-util/grapejuice/grapejuice-7.5.1.ebuild
index c490dec..f559fa7 100644..120000
--- a/games-util/grapejuice/grapejuice-7.5.1.ebuild
+++ b/games-util/grapejuice/grapejuice-7.5.1.ebuild
@@ -1,62 +1 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit xdg
-
-DESCRIPTION="A Wine+Roblox management application"
-HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
-SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="mirror"
-
-DEPEND="app-arch/unzip
- dev-libs/gobject-introspection
- dev-libs/openssl[abi_x86_32]
- dev-python/click
- dev-python/pygobject
- dev-python/packaging
- dev-python/pip
- dev-python/psutil
- dev-python/requests
- dev-python/setuptools
- dev-python/unidecode
- dev-util/desktop-file-utils
- dev-util/gtk-update-icon-cache
- media-libs/libpulse[abi_x86_32]
- media-libs/mesa
- net-libs/gnutls[abi_x86_32]
- x11-libs/cairo
- x11-libs/gtk+
- x11-misc/shared-mime-info
- x11-misc/xdg-user-dirs
- x11-misc/xdg-utils"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- default
- mv ${WORKDIR}/grapejuice-v${PV} ${S}
-}
-
-src_compile() {
- cd ${S}
- export PYTHONPATH="${S}/src"
- python3 -m grapejuice_packaging linux_package
-}
-
-src_install() {
- export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
- tar -xf ${S}/dist/linux_package/*.tar.gz -C ${D}
- mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}"
- rm -r "${D}/usr/lib/python3"
- default
-}
-
-pkg_postinst() {
- optfeature "Wine is required to run Roblox, but left out of depends to let the user decide on custom builds" app-emulation/wine
- optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
-}
+grapejuice-5.3.3.ebuild \ No newline at end of file
diff --git a/games-util/grapejuice/grapejuice-7.6.2.ebuild b/games-util/grapejuice/grapejuice-7.6.2.ebuild
index c490dec..f559fa7 100644..120000
--- a/games-util/grapejuice/grapejuice-7.6.2.ebuild
+++ b/games-util/grapejuice/grapejuice-7.6.2.ebuild
@@ -1,62 +1 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit xdg
-
-DESCRIPTION="A Wine+Roblox management application"
-HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
-SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="mirror"
-
-DEPEND="app-arch/unzip
- dev-libs/gobject-introspection
- dev-libs/openssl[abi_x86_32]
- dev-python/click
- dev-python/pygobject
- dev-python/packaging
- dev-python/pip
- dev-python/psutil
- dev-python/requests
- dev-python/setuptools
- dev-python/unidecode
- dev-util/desktop-file-utils
- dev-util/gtk-update-icon-cache
- media-libs/libpulse[abi_x86_32]
- media-libs/mesa
- net-libs/gnutls[abi_x86_32]
- x11-libs/cairo
- x11-libs/gtk+
- x11-misc/shared-mime-info
- x11-misc/xdg-user-dirs
- x11-misc/xdg-utils"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- default
- mv ${WORKDIR}/grapejuice-v${PV} ${S}
-}
-
-src_compile() {
- cd ${S}
- export PYTHONPATH="${S}/src"
- python3 -m grapejuice_packaging linux_package
-}
-
-src_install() {
- export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
- tar -xf ${S}/dist/linux_package/*.tar.gz -C ${D}
- mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}"
- rm -r "${D}/usr/lib/python3"
- default
-}
-
-pkg_postinst() {
- optfeature "Wine is required to run Roblox, but left out of depends to let the user decide on custom builds" app-emulation/wine
- optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
-}
+grapejuice-5.3.3.ebuild \ No newline at end of file
diff --git a/games-util/grapejuice/grapejuice-7.7.2.ebuild b/games-util/grapejuice/grapejuice-7.7.2.ebuild
index c490dec..f559fa7 100644..120000
--- a/games-util/grapejuice/grapejuice-7.7.2.ebuild
+++ b/games-util/grapejuice/grapejuice-7.7.2.ebuild
@@ -1,62 +1 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit xdg
-
-DESCRIPTION="A Wine+Roblox management application"
-HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
-SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="mirror"
-
-DEPEND="app-arch/unzip
- dev-libs/gobject-introspection
- dev-libs/openssl[abi_x86_32]
- dev-python/click
- dev-python/pygobject
- dev-python/packaging
- dev-python/pip
- dev-python/psutil
- dev-python/requests
- dev-python/setuptools
- dev-python/unidecode
- dev-util/desktop-file-utils
- dev-util/gtk-update-icon-cache
- media-libs/libpulse[abi_x86_32]
- media-libs/mesa
- net-libs/gnutls[abi_x86_32]
- x11-libs/cairo
- x11-libs/gtk+
- x11-misc/shared-mime-info
- x11-misc/xdg-user-dirs
- x11-misc/xdg-utils"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- default
- mv ${WORKDIR}/grapejuice-v${PV} ${S}
-}
-
-src_compile() {
- cd ${S}
- export PYTHONPATH="${S}/src"
- python3 -m grapejuice_packaging linux_package
-}
-
-src_install() {
- export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
- tar -xf ${S}/dist/linux_package/*.tar.gz -C ${D}
- mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}"
- rm -r "${D}/usr/lib/python3"
- default
-}
-
-pkg_postinst() {
- optfeature "Wine is required to run Roblox, but left out of depends to let the user decide on custom builds" app-emulation/wine
- optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
-}
+grapejuice-5.3.3.ebuild \ No newline at end of file
diff --git a/games-util/grapejuice/grapejuice-7.8.2.ebuild b/games-util/grapejuice/grapejuice-7.8.2.ebuild
index c490dec..f559fa7 100644..120000
--- a/games-util/grapejuice/grapejuice-7.8.2.ebuild
+++ b/games-util/grapejuice/grapejuice-7.8.2.ebuild
@@ -1,62 +1 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit xdg
-
-DESCRIPTION="A Wine+Roblox management application"
-HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
-SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="mirror"
-
-DEPEND="app-arch/unzip
- dev-libs/gobject-introspection
- dev-libs/openssl[abi_x86_32]
- dev-python/click
- dev-python/pygobject
- dev-python/packaging
- dev-python/pip
- dev-python/psutil
- dev-python/requests
- dev-python/setuptools
- dev-python/unidecode
- dev-util/desktop-file-utils
- dev-util/gtk-update-icon-cache
- media-libs/libpulse[abi_x86_32]
- media-libs/mesa
- net-libs/gnutls[abi_x86_32]
- x11-libs/cairo
- x11-libs/gtk+
- x11-misc/shared-mime-info
- x11-misc/xdg-user-dirs
- x11-misc/xdg-utils"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- default
- mv ${WORKDIR}/grapejuice-v${PV} ${S}
-}
-
-src_compile() {
- cd ${S}
- export PYTHONPATH="${S}/src"
- python3 -m grapejuice_packaging linux_package
-}
-
-src_install() {
- export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
- tar -xf ${S}/dist/linux_package/*.tar.gz -C ${D}
- mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}"
- rm -r "${D}/usr/lib/python3"
- default
-}
-
-pkg_postinst() {
- optfeature "Wine is required to run Roblox, but left out of depends to let the user decide on custom builds" app-emulation/wine
- optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
-}
+grapejuice-5.3.3.ebuild \ No newline at end of file
diff --git a/games-util/grapejuice/grapejuice-7.8.3.ebuild b/games-util/grapejuice/grapejuice-7.8.3.ebuild
index c490dec..f559fa7 100644..120000
--- a/games-util/grapejuice/grapejuice-7.8.3.ebuild
+++ b/games-util/grapejuice/grapejuice-7.8.3.ebuild
@@ -1,62 +1 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit xdg
-
-DESCRIPTION="A Wine+Roblox management application"
-HOMEPAGE="https://gitlab.com/brinkervii/grapejuice.git"
-SRC_URI="https://gitlab.com/brinkervii/grapejuice/-/archive/v${PV}/grapejuice-v${PV}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="mirror"
-
-DEPEND="app-arch/unzip
- dev-libs/gobject-introspection
- dev-libs/openssl[abi_x86_32]
- dev-python/click
- dev-python/pygobject
- dev-python/packaging
- dev-python/pip
- dev-python/psutil
- dev-python/requests
- dev-python/setuptools
- dev-python/unidecode
- dev-util/desktop-file-utils
- dev-util/gtk-update-icon-cache
- media-libs/libpulse[abi_x86_32]
- media-libs/mesa
- net-libs/gnutls[abi_x86_32]
- x11-libs/cairo
- x11-libs/gtk+
- x11-misc/shared-mime-info
- x11-misc/xdg-user-dirs
- x11-misc/xdg-utils"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- default
- mv ${WORKDIR}/grapejuice-v${PV} ${S}
-}
-
-src_compile() {
- cd ${S}
- export PYTHONPATH="${S}/src"
- python3 -m grapejuice_packaging linux_package
-}
-
-src_install() {
- export PYTHON_VERSION=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
- tar -xf ${S}/dist/linux_package/*.tar.gz -C ${D}
- mv "${D}/usr/lib/python3/dist-packages" "${D}/usr/lib/python${PYTHON_VERSION}"
- rm -r "${D}/usr/lib/python3"
- default
-}
-
-pkg_postinst() {
- optfeature "Wine is required to run Roblox, but left out of depends to let the user decide on custom builds" app-emulation/wine
- optfeature "Required for PRIME systems running XOrg, where XRandR based profiling is desired" x11-apps/xrandr
-}
+grapejuice-5.3.3.ebuild \ No newline at end of file