aboutsummaryrefslogtreecommitdiffstats
path: root/dev-python/anitopy/anitopy-2.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/anitopy/anitopy-2.1.1.ebuild')
-rw-r--r--dev-python/anitopy/anitopy-2.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/anitopy/anitopy-2.1.1.ebuild b/dev-python/anitopy/anitopy-2.1.1.ebuild
new file mode 100644
index 0000000..a252505
--- /dev/null
+++ b/dev-python/anitopy/anitopy-2.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+inherit distutils-r1
+
+DESCRIPTION="Python library for parsing anime video filenames"
+HOMEPAGE="https://github.com/igorcmoura/anitopy"
+
+if [[ "${PV}" == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/igorcmoura/anitopy.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/igorcmoura/anitopy/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pip"
+
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"