aboutsummaryrefslogtreecommitdiffstats
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/anchor-kr/Manifest3
-rw-r--r--dev-python/anchor-kr/anchor-kr-0.1.3.ebuild34
-rw-r--r--dev-python/anchor-kr/metadata.xml11
-rw-r--r--dev-python/anitopy/Manifest3
-rw-r--r--dev-python/anitopy/anitopy-2.1.1.ebuild29
-rw-r--r--dev-python/anitopy/metadata.xml11
6 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/anchor-kr/Manifest b/dev-python/anchor-kr/Manifest
new file mode 100644
index 0000000..2779f95
--- /dev/null
+++ b/dev-python/anchor-kr/Manifest
@@ -0,0 +1,3 @@
+DIST anchor-0.1.3.tar.xz 6052 BLAKE2B 4e0bbf992d3c0e5950767902e2cd8a8c3eb88ec63622cf4dfda2849e62cbe0ac882c3030ac146b9f5035261d6305e8c7f6c596e41801076d335f7d8a009ba3b0 SHA512 b1f36eeaaab16a61fe6c8f795fb4f35157a5b80fbdd643c0345ac6e35b076312305fe055d0867a0dd170cf4cae2ea30d495664d4dfb85cc945a8548eaee5ab3e
+EBUILD anchor-kr-0.1.3.ebuild 732 BLAKE2B 22d2db5ac73b2691aaa180c877bbce8b0839f2bfd04dcbf3b07d301ac6339494a65fd13fa163ba05421d8c1bc4bb3b9ba607611b514a3e8d2f1e0a9293af594f SHA512 cf8c03aee7d06a5f13bc4b9de764ddf6904b5a1fbac2d5dd0f43029bcd746efc8baf22ced48f54559d8c9412dff4edee827ff4c14329de6601d0d3de81c84159
+MISC metadata.xml 360 BLAKE2B 8917a17859b2d90872730ffab30abea999b17b810cde7840a99c60e5deee88ddd57786e1eab49d9bac8766b0630d6b44d5a0f2ae7517c216c3094a0f14180810 SHA512 8e370b0cdd9db492e5f0f7091e98a573b175c93655b0542d0672f4ebc4bb05824cd6e1beac59061f90c3fb15dba3d2e07d163540a4b888768e2b73bd6a8c4904
diff --git a/dev-python/anchor-kr/anchor-kr-0.1.3.ebuild b/dev-python/anchor-kr/anchor-kr-0.1.3.ebuild
new file mode 100644
index 0000000..18fa779
--- /dev/null
+++ b/dev-python/anchor-kr/anchor-kr-0.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+inherit distutils-r1
+
+DESCRIPTION="Me, you and anchor make your scraper complete."
+HOMEPAGE="https://github.com/justfoolingaround/anchor"
+
+if [[ "${PV}" == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/justfoolingaround/anchor.git"
+ inherit git-r3
+else
+ SRC_URI="https://cdn.turret.cyou/0f429b456bca42d4c74cb70e412abe03356b401e/anchor-0.1.3.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pip"
+
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ mv "anchor-${PV}" "${P}" || die
+}
diff --git a/dev-python/anchor-kr/metadata.xml b/dev-python/anchor-kr/metadata.xml
new file mode 100644
index 0000000..281c49c
--- /dev/null
+++ b/dev-python/anchor-kr/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>turret@turret.cyou</email>
+ <name>turret</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">justfoolingaround/anchor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/anitopy/Manifest b/dev-python/anitopy/Manifest
new file mode 100644
index 0000000..aa87077
--- /dev/null
+++ b/dev-python/anitopy/Manifest
@@ -0,0 +1,3 @@
+DIST anitopy-2.1.1.tar.gz 36055 BLAKE2B 2df78d4a841af53c44d83c9fcb07b637e048cbc9418ae1adc11eae598105b89ebe500c02acb183fe7a5c5c1645a4e3e4fba513944af447353496099003854510 SHA512 be8024701dc63aa0366b8b9d7c649f25791a04ef6dbcaf13236aec76fb6694d22a68c30ab9bc78dd250fa482415df533cbcec8986817b1c2a9bdb8b43c16a516
+EBUILD anitopy-2.1.1.ebuild 662 BLAKE2B f93bbae8cf6e4403f1807f4502c9ac1a9a2a73ed2b04cc1ea675a77f5bbafe77403adf2d351eadcc31b39b3ec76080cfae1705758491eac669be74d7aabaac15 SHA512 f6648091cc792d898b4356bfaed7f75f905131316fe4842591c7fcdef43c09fb237e0ed8b2dd7f98133d92a4aaa6ffa4899efa1bc66382b56f54ab906b6221e0
+MISC metadata.xml 354 BLAKE2B ba3a69d5e158d6c80e1f913ac99fc32fe04d13c959034041498194ac7d47fd529564d2d9000d58d9f2f5bdaa9a5b89c07ef6534606b4056d1c2bda8ad9be9aa3 SHA512 31980c7268e3ccb651f0df67a5b65ef1357ea9c352e8a24a18a33f21fe720acfe23ba5c5459061d42628a0ec1f3c186184232d26aa852139beccb5ee1a68790c
diff --git a/dev-python/anitopy/anitopy-2.1.1.ebuild b/dev-python/anitopy/anitopy-2.1.1.ebuild
new file mode 100644
index 0000000..a252505
--- /dev/null
+++ b/dev-python/anitopy/anitopy-2.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+inherit distutils-r1
+
+DESCRIPTION="Python library for parsing anime video filenames"
+HOMEPAGE="https://github.com/igorcmoura/anitopy"
+
+if [[ "${PV}" == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/igorcmoura/anitopy.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/igorcmoura/anitopy/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pip"
+
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
diff --git a/dev-python/anitopy/metadata.xml b/dev-python/anitopy/metadata.xml
new file mode 100644
index 0000000..eb80300
--- /dev/null
+++ b/dev-python/anitopy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>turret@turret.cyou</email>
+ <name>turret</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">igorcmoura/anitopy</remote-id>
+ </upstream>
+</pkgmetadata>